NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I made a change to the street outside my home. (Carroll Street in Brooklyn, NY, USA at -73.96001 40.66824, does not bridge the open tracks of the NYC Subway "S" line; instead, the street dead-ends for automobiles both from the east and the west at sets of bollards whilst a pedestrian bridge connects the two street segments over the tracks. Carroll Street is the only street in the immediate vicinity where such an interruption occurs.) I clicked "Save" and have, many times over a several days, received an error. The "Saved Changes" dialogue box appears with the message

 Failed when uploading data

...and within the dialogue box, a pop-up window reads


 Couldn't upload data: HTTP request error.

...with an "OK" button to acknowledge the error. What could be going wrong? Gee, I wouldn't want anyone to get lost attempting to drive an automobile across Carroll Street at that point.


LATER EDIT: I am using Potlatch on Firefox 4.0.1 in Windows XP, Service Pack 3

STILL FURTHER LATER EDIT: (BTW: If my save error cannot be fixed, I would be delighted if someone else could snip the street, trim back the snipped ends, place the bollards at either terminus, and connect them with a footpath. This is right outside my apartment building and, apart from Google Maps, very few maps I've seen properly indicate that one cannot drive on Carroll from Washington to Franklin!)

ANOTHER FURTHER EDIT (UPDATE): Attempting the identical edit 12 June 2011 from a friend's computer in a different county gives the same error.

asked 05 Jun '11, 17:17

AnnuitCoeptis's gravatar image

accept rate: 0%

edited 12 Jun '11, 16:18

As I didn't hear about any recent API problems I suspect that it is some networking issue. Are you using some kind of proxy or webfilter?

(05 Jun '11, 17:52) petschge

No proxy and no web filters present to my knowledge. No peculiar security features in Firefox. Turning off MS Firewall doesn't help.

(05 Jun '11, 19:13) AnnuitCoeptis

Does it work now? I was getting this over the weekend a couple of times and the other message about 'cannot load the map' (which there are other posts about on here), so hopefully it was just a glitch...

permanent link

answered 06 Jun '11, 07:51

c2r's gravatar image

accept rate: 18%

No, sorry. Still doesn't work. Since I created an account and attempted to save this edit (about a week and a half, perhaps), I have received only this error.

(06 Jun '11, 14:15) AnnuitCoeptis

Do you know if it is Potlatch 1 or 2 you are using?

(06 Jun '11, 14:19) c2r

Potlatch 2

(06 Jun '11, 14:20) AnnuitCoeptis

Is it just the one 'way' you're having trouble editing with, or is it any save of data anywhere?

Do you get the same issue when running from both IE and firefox? Can you access the flash settings?

(06 Jun '11, 15:29) c2r

[bump] Edited original post with update: Different PC gives same error.

(12 Jun '11, 16:20) AnnuitCoeptis

If you think it might be a bug in the editor, we need exact steps to reproduce it. Something like: select Upper Throgmorton Street, click the node at the junction with Frog Lane, click the "scissors icon", click elsewhere on the map to deselect, click the "Save" button, enter "Split Upper Throgmorton Street" in the comments box, click the "Save" button.

permanent link

answered 12 Jun '11, 16:23

Richard's gravatar image

Richard ♦
accept rate: 18%

Could the problem be with some sort of proxy server? I am in Spain and if I use Merkaator I get a HTTP error when I upload changes. If I connect via a VPN to a machine in England the upload will work - as if something is in the way in Spain. Could something similar be happening here?

permanent link

answered 16 Jul '11, 00:08

RobChafer's gravatar image

accept rate: 0%

Sounds likely, except that he's now said "a friend's computer in a different county gives the same error.". Whatever it was, if it was an intermittent issue it was probably solved nearly a year ago.

(28 May '12, 11:15) SomeoneElse ♦

I may be unable to contribute more to the investigation: Internet-deprived for many months, I've just seen the new comments posted here and discovered an edit to insert to Carroll Street footbridge was made sometime in the last year.

HOWEVER: I HAVE been able to add the bollards at either end of the bridge and I've also renamed it, indicated cars are prohibited, cyclists should dismount, it's surfaced in concrete, it's 2.5M wide, &c. These edits have all saved just fine. It is worth noting I am now connecting via a entirely different router and likely a different ISP, as well.

Interesting thing: Whoever inserted the bridge did so WITHOUT snipping the street, as I had attempted to do when I encountered my initial "Save Failed" error. He just placed additional edit points at two places in the roadway and designated them as a type of bridge. Since Carroll Street remained uncut, his bridge remained part of the roadway. I felt this was not an ideal depiction. I was able to delete his bridge, trim back the dangling edges of the roadway, and draw in an entirely new footbridge that can in no way be mistaken as operationally part of Carroll Street where motor vehicles are concerned. It cannot possibly be mistakenly used for routing for motor vehicle traffic.

I hope the sum of all these edits results in the proper depiction of the footbridge for routing and other purposes.

Many thanks to all for your various efforts and valuable time.

permanent link

answered 30 May '12, 21:29

AnnuitCoeptis's gravatar image

accept rate: 0%


I've already seen that. It generally occurs when the uploaded way that was splitted required updating a huge parent relation with many members : the server-side validation of the coherence of data sometimes take too much time, and will timeout before it is really computed. The problem comes when that huge parent relation has been edited by someone else since the time when you downloaded the data : the server-side test for checking conflicts will try to identify several hundreds of nodes, if this affected relation was the country border (in a country with a maritime border).

In order to pass the server-side validation, you have to wait for a time where the server is much less busy. Sometimes as well, this is caused by a bug in JOSM that forgot to download correctly the parent relations.

Sometimes you can solve the problem by saving your work in an .OSM file, then exiting JOSM, then relauching it. If your change requires downloading lots of data from a parent relation, you may also have a problem of memory : some modifications are impossible to make with the 32-bit installation of Java and require the 64-bit version to allow for a Java VM size larger than 1.5 GB (you can go up to 2.5 GB in Windows 7, provided that you have enough RAM, but for more, you may need the 64-bit version to exceed the 4 GB limit).

Finally be aware of problems caused by NAT-rouring in your DSL/cable/fiber access modem : they may close prematurely an HTTP/TCP session that appears idle for two long while the server is still busy computing its response.

permanent link

answered 28 May '12, 08:54

Verdy_p's gravatar image

accept rate: 0%


"this is caused by a bug in JOSM"

I doubt that very much given that the OP said he was using Potlatch 2.

(28 May '12, 10:02) Richard ♦

Your reply is stupid. Ho do you think that Potlatch works when it submits data to the server ? It performs a remote connection (even if this is executed in Javascript by your browser) just like what JOSM does. During these submissions to the API, the request mays ALSO fail with timeouts one the server, or HTTP session cancellation in your router or proxy or firewall (this is more frequent if you use mobile Internet, whose sessions have very short life and will be closed by the ISP if there's still no response after waiting some minutes). The NAT router may be the cause of such problems !

(05 Aug '13, 08:51) Verdy_p

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 05 Jun '11, 17:17

question was seen: 8,164 times

last updated: 05 Aug '13, 08:51

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum