I have freshly installed Nominatim on a brand new server and went through all the instructions to import the full planet osm data. All worked well and I have a Nominatim installation working now, capable of doing search and reverse search. I downloaded the full planet file on the 5th of March 2017, and it took a bit less than a couple of weeks to index, and now it is running fine. The home page displays:

Data last updated: 2017/02/28 23:58GMT.

I suppose this is the date the OSM file was generated.

I have now tried to set up the updater and after installing osmosis I updated the settings in local.php as follows:

@define('CONST_Osmosis_Binary', '/usr/bin/osmosis');    
@define('CONST_Replication_Url', 'http://planet.openstreetmap.org/replication/day');
@define('CONST_Replication_MaxInterval', '3600');
@define('CONST_Replication_Update_Interval', '60');  // How often upstream publishes diffs
@define('CONST_Replication_Recheck_Interval', '60'); // How long to sleep if no update found yet

I changed to use day replication because I wanted to recover 3 weeks of updates or so, and updating every day is enough for me. Then I did:

./utils/setup.php --osmosis-init
./utils/setup.php --create-functions --enable-diff-updates

And finally ran this:

nohup ./utils/update.php --import-osmosis-all &

It seemed to be doing a lot of stuff and took quite a number of hours to stop outputing logs. It seems to be running periodically too.

However, Nominatim's web page is still showing that the Data last updated: 2017/02/28 23:58GMT.

How to I check if osmosis is really updating correctly?

My configuration.txt has the following:

# The URL of the directory containing change files.
baseUrl=http://planet.openstreetmap.org/replication/day

# Defines the maximum time interval in seconds to download in a single invocation.
# Setting to 0 disables this feature.
maxInterval = 3600

I have this in my state.txt:

#Wed Mar 29 20:46:08 CEST 2017
sequenceNumber=1659
timestamp=2017-03-29T00\:00\:00Z

I've tried to change the maxInterval to 0, in case that was affecting it. Did it 4 hours ago, but still the data last updated time is the same.

The output of update.php is showing lines like:

  Done 75495 in 11397 @ 6.624112 per second - Rank 26 ETA (seconds): 17284.882812
  Done 75498 in 11398 @ 6.623794 per second - Rank 26 ETA (seconds): 17285.261719
  Done 75506 in 11398 @ 6.624496 per second - Rank 26 ETA (seconds): 17282.222656
  Done 75515 in 11399 @ 6.624704 per second - Rank 26 ETA (seconds): 17280.320312

What could be the reason the data is not updating properly?

asked 29 Mar '17, 22:30

jbx1's gravatar image

jbx1
11335
accept rate: 0%

edited 29 Mar '17, 22:31

Did the update script finish? It starts with rank 2 and goes to rank 30. Rank 30 (buildings) usually takes twice as long as rank 28. When I see ETA 17000 seconds that's 5 further just for rank 28 to finish, then a new ETA for rank 30 will be shown.

(30 Mar '17, 10:13) mtmail

Well I restarted yesterday with that change in setting of MaxInterval to 0 in configuration.txt and local.php. It is still in Rank 26 it seems! Is it normal to take so long to update? I have this now: Done 185023 in 77387 @ 2.390880 per second - Rank 26 ETA (seconds): 2078.314697 Done 185023 in 77388 @ 2.390849 per second - Rank 26 ETA (seconds): 2078.341553

(30 Mar '17, 16:50) jbx1

It is still running (after the restart of the 30th of March) and still the Data last updated date is the same. At some point it was doing Rank 27, now it is again doing Rank 19.
Done 19201 in 1745 @ 11.003438 per second - Interpolation lines ETA (seconds): 3569.702393 Done 13022 in 5464 @ 2.383236 per second - Rank 19 ETA (seconds): 19723.605469

Should I restart it? Will it resume if I stop it? Can I do something about it?

(04 Apr '17, 21:50) jbx1
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×549
×216
×163

question asked: 29 Mar '17, 22:30

question was seen: 1,894 times

last updated: 04 Apr '17, 21:51

powered by OSQA