I'm working on a project with Arcmap. I downloaded an OSM file of Munich from openstreetmap.org then I imported this file into Arcmap using OpenStreetMap Toolbox . I have the list of points , lines and polygones . My questions are :

  1. How can I get informations from osm, i.e.,how it is translated to arcgis format
  2. How is route information(number, type (bus/tram), direction, stops) stored? e.g., in attribute table route column is empty

asked 20 Mar, 17:07

tygaf's gravatar image

tygaf
11112
accept rate: 0%

edited 25 Mar, 09:28

aseerel4c26's gravatar image

aseerel4c26 ♦
28.3k14211486

1

Please do not and further questions as answers, wither edit your original question of add comments.

The obvious people to ask are ESRI btw.

(17 Apr, 10:27) SimonPoole ♦

Hi tygaf, the Osm data you downloaded only contain points, lines, and polylines. Busroutes are in Osm as Relations. These are lists of Ways ("Lines" in your software). Train/Tram routes are also there as Relations. The popular node type bicycle routes are also there in Relations.

In JOSM you could download a small part of Munich which contains a little bit of a Route you want in Arcmap. If you activate that way you will see the Relation on the right side. If you open the Relation Editor from that panel you can download the rest of that relation. Copy that Relation to a new layer and export from Josm.

The native format in Osm is a (compressed) type of markup language : XML. Long text with with markers symilar to HTML. Your Geo software wants it in the form of a Database: a table with Columns. That is the reason most Colums are empty. Most of your Polylines don't have a value for the tag "amenety"

The conversion from Osm XML to a Database can also be done with Osm2Pgsql. You will have to choose what type of tag-value pairs you want in your PostgreSQL Database. Unfortunately this only works in Linux for me and the learning curve for Osm2Pgsql is steeper than the one for JOSM.

hth -- Gys

permanent link

answered 17 Apr, 12:27

Gys%20de%20Jongh's gravatar image

Gys de Jongh
3861411
accept rate: 12%

Can we import the needed info separately , with python toolbox ?

(18 Apr, 18:08) tygaf

Hi tygaf, you say you downloaded an OSM file of Munich from openstreetmap.org. If this file only contained lists of points , lines and polygones I guess that you somehow got a raw .pdf file that was already processed (by osm2pgsql ?) Maybe you downloaded it from http://download.geofabrik.de/ ? The .shp files from that site typically contain only the list of points , lines and polygones and no other information that is present in the *.pbf file.

What you actually need is the original raw data file of Munich. The .pbf file and than process that file yourself with Osm2pgsql to extract the data you want in one or more .shp files.

In Qgis the process is a bit more straight forward. You can actually download the Munich area which is then presented as a large number of .shp files (thus not only three) from which you can retain the .shp files you need. Route information will be in relations which are not in the standard GeoFabrik extracts.

I don't know if the same can be done in Arcmap. If not you could try Qgis which is opensource and free.

hope this help a bit Gys

permanent link

answered 20 Mar, 21:00

Gys%20de%20Jongh's gravatar image

Gys de Jongh
3861411
accept rate: 12%

I downloaded an OSM file of Munich from openstreetmap.org and when I loaded it in ArcMap I get this alt text

alt text

I don't get why all column in attribute table are empty

(07 Apr, 15:02) tygaf
2

They aren't all empty. The objects visible in your second screenshot are all highway=* and that attribute is present. That type of object (a road or trail of some kind) wouldn't normally have the other tags like building=*, natural=*, railway=*, etc., so it's expected that those other columns would be empty. If you scroll to the right, do you see a "name" column populated with values?

(07 Apr, 16:48) alester

You said in JOSM I can download a small part of Munich which contains a little bit of a Route I want in Arcmap. If I activate that way I will see the Relation on the right side which I did but I don't know how to download the rest of that relation, copy that Relation to a new layer and export from Josm.

permanent link

answered 08 Jun, 11:48

tygaf's gravatar image

tygaf
11112
accept rate: 0%

Hi tygaf Open Josm File => Download from Osm... goto Tab Slippy map Browse the slippy map to Munich I downloaded a small region around Petersplatz

File=>New Layer this is Data Layer 2

In the Layer panel on the right Select Data Layer 1 (again) make it visible by clicking on the little eye on the left side of it and activate Data Layer 1 by clicking the layer icon at the bottom of this panel

In the relations panel on the right side scroll down to find all the relations you want and please note that some are incomplete (outside the area you downloaded) For your purpose you must first make the relations you want complete. There are two ways to get them complete. 1) via the relation itself, 2) Via it's parent relation.

Example for 1) : select route("Bus 132:Forstenrieder Park => Marienplatz", 196 members, incomplete)

Call the relation editor for selected relation by clicking on the icon at the bottom of the relation panel

In the Edit relation #3,657,886 in layer 'Data Layer1' panel goto the Tags and Members Tab.

In the Refers to column you see a lot of incomplete members

Look carefully at the far left side. There is an icon of a harddisk with a little green arrow on top of it. Click on it to download the incomplete members.

Continue with Example for 2) In the the Edit relation #3,657,886 in layer 'Data Layer1' panel goto the parent Relations Tab

There is the parent relation : route_master("Bus132",2members) Select this parent relation

Click Edit at the bottom of this panel A new relation editor panel will now open : Edit relation #3,657,914 in 'Data Layer1'

goto the Child Relations Tab to see the two child relations of which only one is still incomplete, but there might be a lot more which you could then to all in one go

Click dowload All Children at the bottom of that panel. Now both children are complete : Bus 132 Forstenrieder Park => Marienplatz and Bus 132 Marienplatz => Forstenrieder Park

Close both Relation Editor Panels

In the Reelations Panel on the right select both relations (Hold <cntrl> or <shift> in the usual way to select more than 1 item) It is of course possible to select all relations you want. Which is only usefull if they are all complete (downloaded)

On the bottom of the relations panel click the icon with the sharp arrow : set the current selection to the list of selected relations

In the main window these will now be purple

On the Toolbar Edit=>Copy

In the layer panel on the right : Select Data Layer 2 Make this layer the active Layer by clicking on the layer icon at the bottom of the layer panel Make this layer visible by clicking on the little eye on it's left side Make Data Layer 1 unvisible by clicking on the little eye on it's left side

On the Tool Bar Edit=>Paste

You should see now a black background with only the two bus relations in purple (because they are still selected) If you click some where in the black background the get their color back.

If you zoom and select you will see the details of the bus relation. Like the name of the streets this bus takes but also the surface=asphalt in the Drygalski-Allee

On the Tool Bar : File=>Save as and choose the name and type of the file

hth Gys

permanent link

answered 08 Jun, 23:58

Gys%20de%20Jongh's gravatar image

Gys de Jongh
3861411
accept rate: 12%

edited 09 Jun, 00:01

Hi Gys , I followed your step but when I load the osm file into arcmap a lot of information are still missing in the attribute table. I really don't get the problem

(15 Jun, 17:29) tygaf

Hi tygaf, you should have all information about the bus routes, relations.

What do you think is missing ?

(15 Jun, 19:05) Gys de Jongh

I don't know I tried everything. Attribute table is always missing information

(18 Jun, 13:11) tygaf

Are you still expecting the attribute table to be completely filled for every object? As I explained above back in April, no single object will have all of the attributes at the same time. Most of the attributes will be blank for most objects.

(19 Jun, 22:10) alester
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×117
×27
×16
×7

question asked: 20 Mar, 17:07

question was seen: 1,067 times

last updated: 19 Jun, 22:10

powered by OSQA