Hello,

I'm in Germany and I work with Windows 7 and Opera, everything completely installed and setup in German. However when I open the openstreetmap via openstreetmap.org the interface (ie.e everything outside the map-area, the "tabs" above, and the info- and link-blocks at the left) is in French. I never have setup anything in French on my computer as I'm not really skilled in French. That problem only appears on my "main" computer, on the other devices (netbook and android phone) which share the same Internet connection (T-Online) everything is completely in German. I haven't found any option on the site openstreetmap.org where I could change this. When I open the openstreetmap via openstreetmap.de everything is correctly on German. However I like the .org-interface more so I'd like to be able to access the openstreetmap also via the .org-link in german.

Regards
Patrick

asked 29 May '11, 14:41

Kurpfaelzer's gravatar image

Kurpfaelzer
36115
accept rate: 0%


Please check Opera settings: Menu->Settings->Preferences..->General->Language: Details.. . You should have have german and english specified there (and any other language you can read) and probably you have frensh also there. If it is there, just delete it or better put it to the end of list.

permanent link

answered 29 May '11, 18:50

RM87's gravatar image

RM87
3.3k23553
accept rate: 23%

Hi RM87,

your hit did the trick, now it works. I was not aware that it's possible to set the preferred languages in websites in Opera. Consequently I at least can't remember that I've changed this. On my "main" computer the settings were (in this order): de-DE, fr, de. Obviously openstreetmap.org doesn't recognize de-DE so it choose fr, now de is the first entry so it chooses this. On my netbook it is de, fr, de-DE, so it takes directly the first choice. Thanks a lot!

Regards
Patrick

(29 May '11, 19:02) Kurpfaelzer

All browsers specify a set of "favored" languages when connecting to a website. Not all websites use that info, but OSM does.

(30 May '11, 16:13) Vincent de P... ♦

A similar problem has been asked already here.

Maybe you have to check the preffered language in the settings of your browser.

permanent link

answered 29 May '11, 18:52

stephan75's gravatar image

stephan75
12.5k453209
accept rate: 6%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×63
×14
×14
×11

question asked: 29 May '11, 14:41

question was seen: 9,037 times

last updated: 30 May '11, 16:13

powered by OSQA