NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

This building https://www.openstreetmap.org/way/60908472 has 400km in length and obviously is a someone's stupid joke. I've tried to delete it three times, everything were commited ok, however the building is still there! please someone remove that building!

asked 22 Nov '16, 11:50

syberrus's gravatar image

syberrus
11112
accept rate: 0%

edited 22 Nov '16, 12:07

escada's gravatar image

escada
19.0k16166302


I'm not sure what you did, but it still in the middle of the sea as far as I can see (see this node history). I've commented on the changeset; I'm sure the original mapper will fix it shortly.

The more general answer is "try and see what went wrong and then (a) talk to the original mapper about it, so they don't do it again, and (b) try and undo what went wrong rather than just deleting".

The steps involved in "try to undo" might be different depending on what else happened in the changeset - it might just need a revert in JOSM, or more manual tidying up might be needed.

permanent link

answered 22 Nov '16, 11:58

SomeoneElse's gravatar image

SomeoneElse ♦
36.9k71370866
accept rate: 16%

i opened the editor, selected the building, click on the trash icon, and press "commit", entered the comment, it said "sending data to server" and then OK. Three times in last several weeks. And it's still there :(

(22 Nov '16, 12:01) syberrus
1

Well, just deleting the "extra-long" building wouldn't have fixed the problem, since the root cause seems to have been dragging a different building into the middle of the sea.

I suspect that the reason that iD (the in-browser editor) is stopping you from deleting things off-screen is by design; as I said above the best course of action here isn't to "just delete it" but to try and find out what happened first.

(22 Nov '16, 12:17) SomeoneElse ♦

The problem has been solved. There was another building in the sea related to the original building. Deleting them both solved the problem

permanent link

answered 22 Nov '16, 12:14

syberrus's gravatar image

syberrus
11112
accept rate: 0%

1

You haven't fixed the problem. There are likely now 2 missing buildings back where they should have been.

(22 Nov '16, 12:22) SomeoneElse ♦

But it's actually all fixed now in https://www.openstreetmap.org/changeset/43869333 .

(22 Nov '16, 13:23) SomeoneElse ♦

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×31

question asked: 22 Nov '16, 11:50

question was seen: 2,180 times

last updated: 22 Nov '16, 13:23

NOTICE: help.openstreetmap.org is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum