Hi all,

I was just trying to upload some changes in Myanmar and got the following error message (in Potlatch & iD):

A server error occurred. Do you want to retry? (The server said: Version mismatch: Provided 3, server had: 4 of Way 380539838)

This way however was not changed by anyone else at the same time. So I don't know why this message appears. Could it be, that this way consists of too many nodes already?

asked 01 Nov '16, 22:55

rene78's gravatar image

accept rate: 0%

edited 02 Nov '16, 08:10

I read on a mailing list that there is a problem with replication of the data from the master database to the slaves. When you upload data it goes to the master database. When you read data it comes from the slave database. When there is a replication problem, the data on the slave databases might be out of date. A newer version might be available on the master database, but you are downloading an old version from the slave.

Just be patient until the operations team has solved the problem. The problem might have been solved by the time I am writing this.

permanent link

answered 02 Nov '16, 06:40

escada's gravatar image

accept rate: 21%


Thanks for the hint. I personally would like to see a small notification somewhere on osm.org to inform about technical issues. Then I would only edit after the problems are solved and don't waste time.

(02 Nov '16, 08:13) rene78

while it is not on the home page (openstreetmap.org), there is a link to https://wiki.openstreetmap.org/wiki/Platform_Status on the homepage of the wiki.

(02 Nov '16, 09:00) escada

Thanks for the tip, , it would be nice to have a specific page to go to if we suspect issues to see if there are indeed issues happening. Like an outage reporting page.

(02 Nov '16, 16:07) Sunfishtommy

@sunfishtommy I'd suggest asking in #osm-dev on IRC. That's where the most up-to-date information will be.

(02 Nov '16, 16:44) SomeoneElse ♦

I am experiencing a very similar problem on JOSM. I download something from the server then make a coupe changes then try to re upload and it says I have version 2 and the object is now on version 4. I update data but it does not detect a mismatch. none of this makes sense, as I literally just downloaded from the server one or 2 minutes before. I was heavily editing one area, and it appears that the data i am uploading to the server is not matching what i am downloading from the server a immediately after.

permanent link

answered 02 Nov '16, 03:39

Sunfishtommy's gravatar image

accept rate: 0%

edited 02 Nov '16, 03:44


I'm seeing the same problem: a conflict which seems to be wrong (server version is 3, my version is 4). I'm not convinced by the above explanation: The data I'm editing was touched for two years ... and when I choose "synchronize", I do not get an edit (I expect "synchronize" would be done from the master server, not the slave in the above scenario ...

Any ideas to get around this, and how I can upload my data??

thanks, nounours77

permanent link

answered 26 Oct '17, 22:10

nounours77's gravatar image

accept rate: 0%

The slave server is the download server. Syncing data uses the same process as downloading data so syncing data will still be coming from the slave server and will not fix any problems you have with mismatched data. The best thing you can do is just wait. the more you try to upload while the slave server is out of date the more errors and problems you are going to make. if you just wait a couple hours and then try to sync the data again it should work. As the guy mentioned above just be patient. Just save the data you have and attempt a sync and up load later.

(26 Oct '17, 22:28) Sunfishtommy

Thanks for your explanation. Still, I do not think it's a problem that goes away. I'm maintaining this data in another database, and nobody else (normally) touches it. All my data does not sync. It did two years ago, but the last attempts were all failing. I'm currently suspecting that something in the JOSM data format has changed, e.g. that not only the version number, but e.g. the date is checked, which wasn't before, and therefore it's rejected. Is there any place where I can learn more about the .osm format used for JSOM files? I did not find.

(26 Oct '17, 22:34) nounours77

OK. SOLVED!!! My problem has nothing to do with the above: I manually increased the version - I thought I must give a higher version after the update. So I said "4", while the actual version is "3". Reading carefully my own manual, I realized that the uploaded data must have the SAME version as the downloaded. Stupid me... but well ... the error message is a bit misleading. Thanks, Sunfishtommy for your help and sorry for bothering.

(26 Oct '17, 22:47) nounours77
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 01 Nov '16, 22:55

question was seen: 1,525 times

last updated: 26 Oct '17, 22:47

powered by OSQA