Hi, someone can help me? I can't install OSM

:~$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:   xenial
cd /mnt/data/
sudo mkdir openstreetmap
sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove
sudo apt-get install g++ make expat libexpat1-dev zlib1g-dev
cd /mnt/data/openstreetmap
wget http://dev.overpass-api.de/releases/osm-3s_v0.7.52.tar.gz
tar xvfz osm-3s_v*.tar.gz
export EXEC_DIR=/mnt/data/openstreetmap/osm-3s_v0.7.52
mkdir db
export DB_DIR=/mnt/data/openstreetmap/db
export PLANET_FILE=/mnt/data/openstreetmap/planet_file
mkdir replicate
export REPLICATE_DIR=/mnt/data/openstreetmap/replicate
cd osm-3s_v*
./configure CXXFLAGS="-O3" --prefix=$EXEC_DIR
make
make install
....
.....
....

Makefile:1101: fallo en las instrucciones para el objetivo 'install-dist_testbinSCRIPTS'
make[2]: *** [install-dist_testbinSCRIPTS] Error 1
make[2]: se sale del directorio '/mnt/data/openstreetmap/osm-3s_v0.7.52/test-bin'
Makefile:1350: fallo en las instrucciones para el objetivo 'install-am'
make[1]: *** [install-am] Error 2
make[1]: se sale del directorio '/mnt/data/openstreetmap/osm-3s_v0.7.52/test-bin'
Makefile:1496: fallo en las instrucciones para el objetivo 'install-recursive'
make: *** [install-recursive] Error 1

Thanks in advance

asked 11 Aug '16, 19:00

arcadio%20ortega's gravatar image

arcadio ortega
26456
accept rate: 0%

edited 11 Aug '16, 21:05

scai's gravatar image

scai ♦
29.4k17263412

Can you provide English messages and the full output of the failing command?

(11 Aug '16, 19:11) scai ♦

Your title is quite misleading. Can you change it to Overpass API, assuming that's what you were planning to install when talking about "installing OSM"?

Also I don't recommend running plain 0.7.52 due to some 64bit issue. If you're not comfortable patching the sources yourself or running a pre-release version, you need to wait for the next release. There's no other workaround available at this time.

(11 Aug '16, 20:54) mmd
1

@mmd I've changed title and tags.

(12 Aug '16, 08:35) scai ♦

I tried on i386 and amd64 with the same result. Yes I managed to install the osm-3s_v0.7.4.tar.gz release. I think the problem is osm-3s_v0.7.52.tar.gz with 16.04. I will wait for a new release. Thanks

(12 Aug '16, 16:39) arcadio ortega
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×50
×46
×37

question asked: 11 Aug '16, 19:00

question was seen: 730 times

last updated: 12 Aug '16, 16:39

powered by OSQA