NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum


I got the following error when I tried to load openstreetmap-carto project into Tile Mill:

roads.mss:2691:10 Property shield-face-name required for defining shield styles.
roads.mss:2688:10 Property shield-face-name required for defining shield styles.
and more ...

Is there any way to fix this error? is there any other IDE to experiment with openstreetmap-carto project?

Since I'm preparing this environment for designers, I prefer to have a WYSIWYG solution rather than running python scripts after each update to get the output.


asked 10 May '16, 10:04

khamooshi's gravatar image

accept rate: 50%

Se pudo encontrar solución a este problema? Estoy teniendo el mismo mensaje de error.

(12 Jun '17, 21:23) jvelazquez

I'm using Kosmtik for rendering osm-carto with some text editor (like Gedit or Atom), but I tried to open current version of osm-carto version with TileOven from git repo just to check if it works:

"TileOven is a maintained fork of TileMill, tested on Linux with Node 0.10.25, 4.2.6, 4.5.0 and 6.9.1 TileOven works only in server mode, no native packages are provided. Platforms other than Linux should theoretically work, but aren't tested."

I was able to run it on Ubuntu 17.10, but unfortunately opening osm-carto was not possible:

[tilemill] Started [Server Core:20009].

[tilemill] [tilemill] skipped loading project: Error: Could not open project.mml file for "openstreetmap-carto". Error was:


[tilemill] "Unexpected token s in JSON at position 0"


[tilemill] (in /home/kocio/Dokumenty/MapBox/project/openstreetmap-carto/project.mml)

permanent link

answered 26 Nov '17, 04:15

kocio's gravatar image

accept rate: 20%

Another option is Kosmtik - depending on what else is installed on yor PC, that may or may not work.

Alternatively, just set up mod_tile and renderd outside of tilemill as per the switch2osm guide, edit the stylesheet with a text editor, run a script that runs "carto" and restarts renderd and apache2, and shoft-reload tiles in your web browser.

permanent link

answered 16 Nov '17, 17:27

SomeoneElse's gravatar image

SomeoneElse ♦
accept rate: 16%

I had a similar problem. I got the same error with 'text-margin' and 'shield-margin'. I opened all of the openstreetmap-carto stylesheets and searched for text-margin and shield-margin. Then, I commented out the lines that had either of that text. I believe TileMill is not being updated and the openstreetmap-carto stylesheets are. So sometimes there are updates made to the stylesheets that TileMill can't handle. Of course commenting these lines out will cause your data to display differently in TileMill but, it will load and be usable. Hope that helps

permanent link

answered 16 Nov '17, 16:36

SeattleHeather's gravatar image

accept rate: 0%

Hi, Did you manage to solve this case? I have a similar problem...

permanent link

answered 02 Aug '16, 10:47

Wojtas82's gravatar image

accept rate: 0%

At what line number (i.e. what was the actual error)?

(02 Aug '16, 10:53) SomeoneElse ♦

alt text

 roads.mss:2681:10 Property shield-face-name required for defining shield styles.
 roads.mss:2678:10 Property shield-face-name required for defining shield styles.


(02 Aug '16, 11:10) Wojtas82

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 10 May '16, 10:04

question was seen: 5,605 times

last updated: 26 Nov '17, 04:15

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum