this is what can be seen while rendering sudo -u tharakk renderd -f -c /usr/local/etc/renderd.conf

renderd[31905]: Rendering daemon started
renderd[31905]: Initiating reqyest_queue
renderd[31905]: Parsing section renderd
renderd[31905]: Parsing render section 0
renderd[31905]: Parsing section mapnik
renderd[31905]: Parsing section default
renderd[31905]: Parsing section style2
renderd[31905]: config renderd: unix socketname=/var/run/renderd/renderd.sock
renderd[31905]: config renderd: num_threads=4
renderd[31905]: config renderd: num_slaves=0
renderd[31905]: config renderd: tile_dir=/var/lib/mod_tile
renderd[31905]: config renderd: stats_file=/var/run/renderd/renderd.stats
renderd[31905]: config mapnik:  plugins_dir=/usr/local/lib/mapnik/input
renderd[31905]: config mapnik:  font_dir=/usr/share/fonts/truetype/ttf-dejavu
renderd[31905]: config mapnik:  font_dir_recurse=1
renderd[31905]: config renderd(0): Active
renderd[31905]: config renderd(0): unix socketname=/var/run/renderd/renderd.sock
renderd[31905]: config renderd(0): num_threads=4
renderd[31905]: config renderd(0): tile_dir=/var/lib/mod_tile
renderd[31905]: config renderd(0): stats_file=/var/run/renderd/renderd.stats
renderd[31905]: config map 0:   name(default) file(/usr/local/share/maps/style/OSMBright/OSMBright.xml) uri(/osm/) htcp() host(localhost)
renderd[31905]: config map 1:   name(style2) file() uri() htcp() host()
renderd[31905]: Initialising unix server socket on /var/run/renderd/renderd.sock
renderd[31905]: Created server socket 4
renderd[31905]: Renderd is using mapnik version 2.2.0
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Bold.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-BoldOblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Italic.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Bold.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-BoldItalic.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Oblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Bold.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Oblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-BoldOblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-BoldOblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Oblique.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-BoldItalic.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Italic.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-ExtraLight.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
renderd[31905]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf
Running in foreground mode...
renderd[31905]: Starting stats thread
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[31905]: Loading parameterization function for 
renderd[31905]: Loading parameterization function for 
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[31905]: Loading parameterization function for 
renderd[31905]: Loading parameterization function for 
renderd[31905]: Using web mercator projection settings
renderd[31905]: Using web mercator projection settings
renderd[31905]: Using web mercator projection settings
renderd[31905]: Using web mercator projection settings

this is what happens when i restart apache

* Restarting web server apache2                                                                                                                                        [Tue Mar 08 12:59:41.710074 2016] [tile:notice] [pid 31978] Loading tile config default at /osm/ for zooms 0 - 20 from tile directory /var/lib/mod_tile with extension .png and mime type image/png

[Tue Mar 08 12:59:41.710146 2016] [tile:notice] [pid 31978] Loading tile config style2 at  for zooms 0 - 20 from tile directory /var/lib/mod_tile with extension .png and mime type image/png
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message

but it will give me pink maps when i try http://localhost:8080/osm/slippymap.html or http://localhost/osm/0/0/0.png giving me the error on the browser

`failed to load resource: net::ERR_CONNECTION_REFUSED`

I found the same problem and tried to change localhost path in slippymap.html but no luck This is my osm layer in slippymap

var layer = new OpenLayers.Layer.OSM('My Layer', '${z}/${x}/${y}.png', {
            format: 'image/png',
            layers: 'my:layer'
        }, {
            ttileOptions: {crossOriginKeyword: 'anonymous'},
            transitionEffect: null
        });
        map.addLayer(layer);

i am using linux mint platform and no Virtual machines involved. I carefully followed the instructions from https://switch2osm.org/serving-tiles/manually-building-a-tile-server-14-04/. I am using apache to load tiles and apache is on port 8080. my /var/lib/mod_tiles look like this after rendering,

tharakk@nimbusthree-G500 /var/lib/mod_tile $ ls -la
total 12
drwxrwxrwx  3 tharakk root    4096 මාර්  11 15:38 .
drwxr-xr-x 79 root    root    4096 මාර්  11 11:42 ..
drwxr-xr-x 13 tharakk tharakk 4096 මාර්  11 16:03 default

http://localhost:8080/mod_tile will return this on browser

NoResp200: 0
NoResp304: 0
NoResp404: 0
NoResp503: 0
NoResp5XX: 0
NoRespOther: 0
NoFreshCache: 0
NoOldCache: 0
NoVeryOldCache: 0
NoFreshRender: 0
NoOldRender: 0
NoVeryOldRender: 0
NoRespZoom00: 0
NoRespZoom01: 0
NoRespZoom02: 0
NoRespZoom03: 0
NoRespZoom04: 0
NoRespZoom05: 0
NoRespZoom06: 0
NoRespZoom07: 0
NoRespZoom08: 0
NoRespZoom09: 0
NoRespZoom10: 0
NoRespZoom11: 0
NoRespZoom12: 0
NoRespZoom13: 0
NoRespZoom14: 0
NoRespZoom15: 0
NoRespZoom16: 0
NoRespZoom17: 0
NoRespZoom18: 0
NoRespZoom19: 0
NoRespZoom20: 0
NoTileBufferReads: 0
DurationTileBufferReads: 0
NoTileBufferReadZoom00: 0
DurationTileBufferReadZoom00: 0
NoTileBufferReadZoom01: 0
DurationTileBufferReadZoom01: 0
NoTileBufferReadZoom02: 0
DurationTileBufferReadZoom02: 0
NoTileBufferReadZoom03: 0
DurationTileBufferReadZoom03: 0
NoTileBufferReadZoom04: 0
DurationTileBufferReadZoom04: 0
NoTileBufferReadZoom05: 0
DurationTileBufferReadZoom05: 0
NoTileBufferReadZoom06: 0
DurationTileBufferReadZoom06: 0
NoTileBufferReadZoom07: 0
DurationTileBufferReadZoom07: 0
NoTileBufferReadZoom08: 0
DurationTileBufferReadZoom08: 0
NoTileBufferReadZoom09: 0
DurationTileBufferReadZoom09: 0
NoTileBufferReadZoom10: 0
DurationTileBufferReadZoom10: 0
NoTileBufferReadZoom11: 0
DurationTileBufferReadZoom11: 0
NoTileBufferReadZoom12: 0
DurationTileBufferReadZoom12: 0
NoTileBufferReadZoom13: 0
DurationTileBufferReadZoom13: 0
NoTileBufferReadZoom14: 0
DurationTileBufferReadZoom14: 0
NoTileBufferReadZoom15: 0
DurationTileBufferReadZoom15: 0
NoTileBufferReadZoom16: 0
DurationTileBufferReadZoom16: 0
NoTileBufferReadZoom17: 0
DurationTileBufferReadZoom17: 0
NoTileBufferReadZoom18: 0
DurationTileBufferReadZoom18: 0
NoTileBufferReadZoom19: 0
DurationTileBufferReadZoom19: 0
NoTileBufferReadZoom20: 0
DurationTileBufferReadZoom20: 0

but when i prerender using it renders like this and metatiles are created in /var/lib/mod_tile folder

cd ~/src/mod_tile
time ./render_list -m default -a -z 0 -Z 10

DEBUG: DONE TILE default 10 264-271 416-423 in 0.523 seconds
renderd[8432]: DEBUG: Sending render cmd(3 default 10/264/416) with protocol version 2 to fd 8
renderd[8432]: DEBUG: Got incoming request with protocol version 2
renderd[8432]: DEBUG: Got command RenderBulk fd(8) xml(default), z(10), x(264), y(424), mime(image/png), options()
renderd[8432]: DEBUG: START TILE default 10 264-271 424-431, new metatile
renderd[8432]: Rendering projected coordinates 10 264 424 -> -9705668.103544|3130860.678562 -9392582.035687|3443946.746419 to a 8 x 8 tile

all looks good but what did i do wrong here? Thank you in advance.

asked 08 Mar '16, 07:53

Tharaka%20Rajith's gravatar image

Tharaka Rajith
26235
accept rate: 0%

edited 11 Mar '16, 11:00

1

Low zoom tiles will typically take substantially longer to render than the browser/whatever timeout. Have you checked that they are not eventually getting created?

I would further suggest checking if there is actually a webserver running on localhost ports 80 and 8080.

(08 Mar '16, 13:39) SimonPoole ♦

Thank You SimonPoole. yes my apache is on port 8080, mod tiles are created in /var/lib/mod_tiles after rendering & also apache is not giving errors when restarting after rendering.i have updated the above path directory.

(09 Mar '16, 04:13) Tharaka Rajith
1

I somehow suspect that mod_tile is not finding your tiles/that there is a config error or difference between renderd.conf and the mod_tile configuration (alternatively your layer config on the test web page might be wrong).

(11 Mar '16, 14:56) SimonPoole ♦

Thank You SimonPoole. Yes my layer config in slippymap.html should be wrong.But I can't think of why http://localhost:8080/mod_tile will give the above result and http:localhost/osm_tiles/0/0/0.png & http://localhost:8080/osm_tiles/0/0/0.png will gice 404 error since i followed Configure renderd, Configure mod_tile only according to https://switch2osm.org/serving-tiles/manually-building-a-tile-server-14-04/

(14 Mar '16, 05:05) Tharaka Rajith
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×419
×81
×71
×33
×6

question asked: 08 Mar '16, 07:53

question was seen: 2,555 times

last updated: 14 Mar '16, 05:21

powered by OSQA