NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I have been using JOSM for some months. Today I wanted to upload my latest edits, but got an OAuth dialog that requested me to enter my (prefilled) credentials. Pressing the "Authorize now" button gives me the error message saying: "The automatic process for retrieving an OAuth Access Token from the OSM server failed. Please try again or choose another kind of authorization process, i.e. semi-automatic or manual autorization."

Then I select the semi-automatic process and press Receive Request Token. A status box appears for a short while and then nothing happens.

When I select the manual process, I don't know where to get the info needed. The dialog does not say and I cannot find anything in my OSM account that looks like it. Not even gives a hint to where to get these.

JOSM is not registered under "My Authorised Applications" on I have used it many times for several months without any issue.

I start JOSM via Java Web Start and have cleared the cache, even waited 5 hours, with no result.

asked 02 Mar '16, 19:01

simonmikkelsen-dk's gravatar image

accept rate: 100%

there, recently, the user also was not successful in setting up OAuth. Hmm ...

I just used JOSM 9900 on openjdk version 1.8.0_74 (64 bit) on Linux to upload changes with an OAuth (which I have set up since a long time) and no Webstart.

Some more info may be useful: Did you use OAuth before (in the "some months") or the plain username+password login for JOSM? Which version of JOSM do you use now? Which Java version? Maybe you just should open a new ticket with your version information (use the JOSM bug report function in JOSM's help menu) - please leave a not here if you do so.

"Register your application" on the "My Authorised Applications" page in your user settings should be the thing which you need for the manual process, but I currently cannot help you any more with that.

(02 Mar '16, 19:08) aseerel4c26 ♦

Note that very recently a new JOSM version was released (2016-02-28: Stable release r9900). The notes list "OAuth improvements" as a "minor enhancement". So maybe that broke something for you. I guess your experience could be related to ticket/7612. There are some recently created tickets about oauth in JOSM. ... maybe ticket/12584 is the same problem you have.

(02 Mar '16, 19:15) aseerel4c26 ♦

One of the bugs referred mentioned a Java upgrade had fixed it. I upgraded to Oracle Java build 1.8.0_74-b02 (64 bit) on my Linux box but it did not fix the issues when I used Java Webstart.

When I downloaded the jar-file and ran it from the command line, it worked. This is good enough for me - as a Java developer I have never been a fan of Java Webstart anyway :-)

permanent link

answered 04 Mar '16, 11:51

simonmikkelsen-dk's gravatar image

accept rate: 100%


I hope you don't mind - I've accepted this as an answer (since you won't be able to do it yourself, since it's your answer to your question).

(04 Mar '16, 11:54) SomeoneElse ♦

Thanks for accepting. I looked for the option but could not find it, so I assumed that rule existed.

(05 Mar '16, 08:11) simonmikkels...

Thanks for the solution! Just for reference: Could you mention which java version you had before? And did you try it without Webstart and that older version?

(05 Mar '16, 09:26) aseerel4c26 ♦

Prev version: java -version java version "1.7.0_80" Java(TM) SE Runtime Environment (build 1.7.0_80-b15) Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)

This version also works when not started with WebStart.

(05 Mar '16, 09:37) simonmikkels...

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 02 Mar '16, 19:01

question was seen: 2,731 times

last updated: 05 Mar '16, 09:37

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum