1
1

Hi all

I'm using the following cli to create a diff file with osmosis :

osmosis --rri workingDirectory=$dir --simc --wxc $diff_file

It works globally fine, but sometimes failed with the following error message : SEVERE: Thread for task 1-rri failed org.openstreetmap.osmosis.core.OsmosisRuntimeException: Pipeline entities are not sorted, previous entity type=Node, id=3976375557, version=1 current entity type=Node, id=3976375557, version=1.

In that case, removing --simc option seems to work fine and generate a correct osc file but it contains several changes for the same id (which is expected because of removing simplify-changes option !). I had a look at the generated file and it seems --simc option is failing when an id is created and deleted in the same osc file compilation (from 2016-01-28 to 2016-02-01 in my case) :

<create> ... <node id="3976375557" version="1" timestamp="2016-01-29T17:16:56Z" uid="3577326" user="Alain 9-0" changeset="36883598" lat="47.5435886" lon="6.8328761"/> </create> <delete> <node id="3976375557" version="1" timestamp="2016-01-31T05:04:40Z" uid="3577326" user="Alain 9-0" changeset="36883598" lat="47.5435886" lon="6.8328761"/> </delete>

Any idea on how to keep --simc option in any case ?

Thanks a lot for any help

Kind regards,

David

asked 01 Feb '16, 10:43

dmercier90's gravatar image

dmercier90
46224
accept rate: 0%

I used osmosis Version 0.40.1 and tried latest 0.44.1 with the same results.

Test files : http://download.geofabrik.de/europe/france/franche-comte-updates/000/001/052.osc.gz to 054.osc.gz

(01 Feb '16, 12:49) dmercier90
2

It seems I've found a piece of answer hier : http://gis.19327.n5.nabble.com/osmosis-dev-Error-on-a-node-modified-and-deleted-in-the-same-changeset-td5759351.html

"I'm currently using a workaround, which is to set maxInterval in configuration.txt to 0.5 day to make sure that osmosis is not trying to merge two diffs. Then I had to add a loop to run osmosis until there are no recent diffs."

Hope this should help someone who's facing the same issue when trying to merge several geofrabrik's file with osmosis

(01 Feb '16, 13:19) dmercier90

Ran into the same problem (also with Geofabrik diffs). The "0.5 day" workaround (setting maxInterval to 43200 in configuration.txt) works for me. Thanks for posting this!

(28 Nov '16, 10:58) inkatlas
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×180
×23

question asked: 01 Feb '16, 10:43

question was seen: 1,373 times

last updated: 28 Nov '16, 10:58

powered by OSQA