Hey everyone,

I am developing a project for my term project and in one of the modules it gets two coordinates from me, finds the shortest path and shows the route. But for about a week now, the plugin doesn't seem to find any route. I double check with the routing server address provided on QT's webpage and tried anything seems like a host address with no luck. I also made contact with Aaron McCarthy from QT to address the problem, still no working solution. But one of he recommended was to run a routing query on OSM website which worked just fine.

What I am asking, -is there any routing server host I can try or test if mine's working, -any known issues anyone experienced working with OSM and/or QT Location API lately ?

Thanks all in advance

asked 30 Dec '15, 00:49

aleqria's gravatar image

aleqria
11112
accept rate: 0%

edited 30 Dec '15, 11:40

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548

Please state which routing server address you are using to make queries.

(30 Dec '15, 08:48) Frederik Ramm ♦

Oh, ok. Here it is : "http://osrm.server.address/viaroute"

(30 Dec '15, 10:16) aleqria
2

osrm.server.address is not a valid domain name, so you won't get any results from there.

(30 Dec '15, 10:31) Richard ♦

it's what presented on http://doc.qt.io/qt-5/location-plugin-osm.html . And the odd thing is this was working perfectly until a week ago. Also valid domain names are welcomed.

(30 Dec '15, 10:55) aleqria

I guess until a week ago you did not specify the (optional!) parameter osm.routing.host. Then it defaulted to http://router.project-osrm.org/viaroute if I understand your linked Qt docu page correctly. http://osrm.server.address/viaroute is just a placeholder address which is used in the example parameter listing.

permanent link

answered 30 Dec '15, 11:37

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548
accept rate: 18%

edited 30 Dec '15, 11:40

Also note that in the description for the "osm.routing.host" parameter, the "URL" link points to the correct address: http://router.project-osrm.org/viaroute

(30 Dec '15, 16:35) alester

I checked the packets being sent in and out using Wireshark and bumped into a packet named Application Data with the content of application.json file which in following struct : http://imagizer.imageshack.us/a/img633/8568/r8O6tK.jpg

I suspect there been some adjustments in Qt side about receiving and parsing the json file.

Any ideas ?

(01 Jan '16, 15:04) aleqria
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×249
×16
×7

question asked: 30 Dec '15, 00:49

question was seen: 2,223 times

last updated: 01 Jan '16, 15:04

powered by OSQA