Hi there, I have added some water elements in an area of meadows (grass-type vegetation).

The larger area is marked with way 346287712. This way has a relation: multipolygon 5640835. The selected role is 'outer'. The relation has the following two keys/values: landuse/meadow and type/multipolygon. This part seems to work, as can be seen here:

link to the map

Inside of the multipolygon I created a number of lakes. The lake that is most south ('Zuiderzee') has an island in it, so I had to create another relation (multopolygon) for the lake. The island is rendered correctly. The water is also rendered, but it has the small tree icons through it, just like the surrounding land.

So my question is: how do I make the water completely blue, without the small tree icons in it?

I have already tried making the water without any relations, this can be seen in the third lake from the south called 't Aelmare. This brings up the same problem.

asked 05 Nov '15, 16:19

_Ari's gravatar image

_Ari
11113
accept rate: 0%

edited 10 Oct '16, 17:11

Your edit is recent, it will take time for it to render, if time does not fix it maybe this is the answer--- http://wiki.openstreetmap.org/wiki/Multipolygon_Examples#Forest_with_two_lakes_and_an_island_.28Nested_multipolygons.29

(05 Nov '15, 19:58) andy mackey

Relation 5640835 has no landuse value, I only see its type. That said, there are lots of trees everywhere, and I don't quite get where they're coming from. Probably, as andy said, time will fix it.

(06 Nov '15, 12:56) joost schouppe

Time didn't fix it, there must still be something wrong with the multipolygon relations. The lakes still contain trees.

(07 Nov '15, 19:14) scai ♦

This place is a mystery. Something is seriously wrong there with the mapnik-carto tiles, almost as if they were write-protected!? Since about a YEAR, despite changes in the meantime. Anyone can figure this out?

http://mc.bbbike.org/mc/?lat=52.2871906&lon=5.52683644&zoom=15&num=3&mt0=mapnik&mt1=osmfr&mt2=osm-no-labels

About a year ago the old forest area was completely restructured to install a new campsite, Scoutinglandgoed Zeewolde. Big parts of the forest cut down, new lakes created, tracks and paths are partly different, and OSM was updated accordingly. But mapnik won't show any of it, no matter what.

Cannot find anything wrong with the areas there, and doubt there is. It's not only the areas, but even the tracks and paths are still cached old, for example a way going through the middle of a new lake. And other renderers do show the updates correctly, no prob.

(09 Oct '16, 15:18) wycbtma

The weirdest thing is: I did already get mapnik to update the tiles correctly, some weeks ago. After a major struggle, and when nothing helped ending up trying brute force (new fake stream all over the area, updated tiles, some minutes later deleted the fake stream again, updated tiles - all looked fine then). But today came across the area again and was shocked: it had actually RESTORED the OLD tiles again! Just for testing tried the fake-stream method again, but this time didn't help a thing anymore. The stream was shown, but the area behind it NOT updated any more. Have deleted all traces of my fixing attemps again.

No idea if it would help to delete and then rebuild the new AREAs there again. But do not want to get involved any deeper there myself, having no local knowledge. Especially not as long as Bing still shows the old forest too.
But cannot imagine it has anything to do with the data anyway, must be some server prob.

(09 Oct '16, 15:18) wycbtma

Is this the "way going through the middle of a new lake"? http://www.openstreetmap.org/?mlat=52.28860&mlon=5.52322#map=17/52.28860/5.52322

I think that's a typical database bug. Something went wrong during the update or the diffs were broken. Now the way remains in the database until someone touches it again or until a complete re-import occurs. Here, touching the way means doing an undelete and then deleting it again. A re-import probably won't happen any time soon since it is very ressource-intensive.

(09 Oct '16, 15:34) scai ♦

So... How long will it probably take for the bug to crawl out of the database if things keep going as usual?

Or what options do we have to chase the bug ourselves? I don't mind doing something to get this sorted, if I need what to do.

(09 Oct '16, 20:29) _Ari

As explained in my previous comment it will stay in the database until the way gets modified again or a re-import occurs.

The way in question seems to be this one: https://www.openstreetmap.org/way/314866940 Maybe someone can revert and delete it again. I tried to do it a few times but I'm always getting timeouts.

(09 Oct '16, 21:33) scai ♦
1

I've undeleted and re-deleted way 314866940. Rendering seems to be fine now for this way, i.e. it disappeared. You may have to clear your browser cache first. Afterwards I did the same for the forest (way 188676289). Let's see if this is enough.

(10 Oct '16, 16:20) scai ♦
showing 5 of 9 show 4 more comments

The trees are gone, thank you scai! Nice to see that this problem is resolved.

permanent link

answered 10 Oct '16, 17:10

_Ari's gravatar image

_Ari
11113
accept rate: 0%

edited 10 Oct '16, 17:10

Yes, but the new forest still doesn't get rendered compared to the other layers. Seems like the whole changeset needs to be reverted and re-applied.

By the way, please use the "add new comment" button if you just want to add a comment instead of an answer (= a solution) to your question.

(10 Oct '16, 17:18) scai ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×106
×65

question asked: 05 Nov '15, 16:19

question was seen: 2,161 times

last updated: 10 Oct '16, 17:18

powered by OSQA