im using this guide for building tile server https://switch2osm.org/serving-tiles/manually-building-a-tile-server-14-04/.

using ubuntu server, and i got to the last step :

sudo mkdir /var/run/renderd
sudo chown username /var/run/renderd
sudo -u username renderd -f -c /usr/local/etc/renderd.conf

in the last command i got this failure :

renderd[1549]: An error occurred while loading the map layer 'default': Postgis Plugin: Bad connection
Connection string : ' db=gis connect_timeout=4'
   encountered during parsing of later 'landuse_gen0' in Layer at line 193 of '/usr/local/share/maps/style/OSMBright/OSMBright.xml'

what could have been the problem ?

asked 25 Oct '15, 20:58

elad159's gravatar image

elad159
367710
accept rate: 0%

edited 25 Oct '15, 21:32

aseerel4c26's gravatar image

aseerel4c26 ♦
32.0k16239550

Hi I have the same error, did you fix that?

(04 Nov '15, 06:15) Zhands

Make sure that the username you are running tirex under ("username" in your example) is the same you created in your PostGIS database as the owner of the OSM database. If you haven't done that then you could perhaps fix it by creating an user named "username" in PostGIS ("createuser -s username").

permanent link

answered 25 Oct '15, 21:13

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
70.6k826391105
accept rate: 24%

i created a user , and then i really have got another results.. its all go fine and it stuck at this point:

renderd[5770]: Loading parameterization function for
renderd[5770]: Loading parameterization function for
renderd[5770]: Starting stats thread
renderd[5770]: Using web mercator projection settings
renderd[5770]: Using web mercator projection settings
renderd[5770]: Using web mercator projection settings
renderd[5770]: Using web mercator projection settings

and it stucks there..

does it ok? by the way another question how am i define a ip server or checking my current using ubuntu server? i tried to use the ipconfig command but it appears to doesnt work..

(25 Oct '15, 22:00) elad159

well i check the mod_tile and i got this reults

NoResp200: 0
NoResp304: 0
NoResp404: 6
NoResp503: 0
NoResp5XX: 0
NoRespOther: 0
NoFreshCache: 0
NoOldCache: 0
NoVeryOldCache: 0
NoFreshRender: 0
NoOldRender: 0
NoVeryOldRender: 0
NoRespZoom00: 0

(up to)

NoRespZoom20: 0
(27 Oct '15, 01:37) elad159
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×230
×99
×53
×29

question asked: 25 Oct '15, 20:58

question was seen: 2,492 times

last updated: 04 Nov '15, 07:58

powered by OSQA