Hello, I'm trying to run osmosis(with mapsforge writer) on Yosemite, but I have encountered a problem. I followed the tutorials, but when I try to run the command I get this:

    GRAVE: Execution aborted.
org.openstreetmap.osmosis.core.OsmosisRuntimeException: Unable to load plugin class ({\rtf1\ansi\ansicpg1252\cocoartf1348\cocoasubrtf170).
    at org.openstreetmap.osmosis.core.TaskRegistrar.loadPluginClass(TaskRegistrar.java:334)
    at org.openstreetmap.osmosis.core.TaskRegistrar.loadPlugin(TaskRegistrar.java:313)
    at org.openstreetmap.osmosis.core.TaskRegistrar.loadBuiltInPlugins(TaskRegistrar.java:123)
    at org.openstreetmap.osmosis.core.TaskRegistrar.initialize(TaskRegistrar.java:80)
    at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:81)
    at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:37)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
    at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
    at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
    at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
    at org.codehaus.classworlds.Launcher.main(Launcher.java:47)
Caused by: java.lang.ClassNotFoundException: {\rtf1\ansi\ansicpg1252\cocoartf1348\cocoasubrtf170
    at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
    at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:244)
    at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:230)
    at org.openstreetmap.osmosis.core.TaskRegistrar.loadPluginClass(TaskRegistrar.java:332)
    ... 14 more

I have no clue what this cocoasubrtf class is, and I could not find any help by googling (quite extensively). Any Ideas?

UPDATE: I have tried running osmosis on Windows as well, and I get the exact same error.

UPDATE 2: I have been suggested to use osmosis 0.44 as a fresh install, and that somehow worked :)

asked 18 Aug '15, 15:09

ZappyKeyboard's gravatar image

ZappyKeyboard
21113
accept rate: 0%

edited 19 Aug '15, 19:45

1

Try asking at the osmosis-dev mailing list although it seems to be pretty low traffic.

(19 Aug '15, 10:28) scai ♦
1

I'd also add details of what tutorials you followed and what the output of "java -version" from the command line is.

(19 Aug '15, 11:23) SomeoneElse ♦
2

I followed the quick install guide on http://wiki.openstreetmap.org/wiki/Osmosis/Quick_Install_%28Windows%29, but I should mention that I had to tinker a bit before making it work: at first it didnt see the jre path, then I had to modify the classworlds pointer in the osmosis file, because it was wrong. I have both java 8 and 7 on my Windows PC.

For mac, a first I downloaded the zipfile and tried running it from there (I used the guide on the wiki). Then I tried downloading osmosis with homebrew. On mac I only have java 8 (for work). Should I try to download java 7 and see if that works?

terminal output on mac: java version "1.8.0_45" Java(TM) SE Runtime Environment (build 1.8.0_45-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)

It's especially odd to me that I get the same error on both machines.

(19 Aug '15, 11:37) ZappyKeyboard

... maybe you can also ask (or do an intensive search for "osmosis" there before) on the mapsforge mailinglist,

see https://groups.google.com/forum/#!forum/mapsforge-dev

(19 Aug '15, 16:41) stephan75
2

It looks like you somehow managed to get RTF encoded text into a context where plain text was expected (all that "{\rtf1\ansi..." stuff smells of RTF). Editing some source or config file with TextEdit.app and accidentally saving as RTF, perhaps?

(21 Aug '15, 07:40) turepalsson
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×219
×25
×8
×1

question asked: 18 Aug '15, 15:09

question was seen: 2,286 times

last updated: 21 Aug '15, 07:40

powered by OSQA