NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum


I just downloaded the latest osmosis build, and it gives me this error

...\osmosis-latest>bin\osmosis Error: Could not find or load main class org.codehaus.classworlds.Launcher

any idea how I could fix this ?


asked 15 Aug '15, 21:08

pfl123456's gravatar image

accept rate: 0%

edited 17 Aug '15, 14:13

neuhausr's gravatar image



It would really help to know what O/S you are using. From the backward slash it looks like windows. Usually this is to do with path variables. I tend to work around this type of problem by running osmosis under windows from its own directory.

(16 Aug '15, 11:12) SK53 ♦

already tried that, no matter where I launch it, it cant find that class

(17 Aug '15, 17:32) pfl123456

windows 7 and no matter where I launch it, it cant find that class

(17 Aug '15, 17:33) pfl123456

usualy I temper javahome, but here it's the very exec that cant find his jar's

(17 Aug '15, 17:35) pfl123456

Does this previous question help? A quick web search for "osmosis classworlds" (without quotes) turns up lots of people asking the same question, and lots of answers.

permanent link

answered 16 Aug '15, 14:59

SomeoneElse's gravatar image

SomeoneElse ♦
accept rate: 16%

I found the following mistake in osmosis.bat: it references plexus-classworlds-2.4.jar but the real name is plexus-classworlds-2.5.2.jar, that solved it

permanent link

answered 24 Sep '15, 22:41

enavarrete's gravatar image

accept rate: 0%

That didn't work for me. I changed to 2.5.2., saved and restartet but nothing changed. When I look in the osmosis.bat the spelling is correct. I have tried multiple versions of osmosis. What can I do?


(15 Jan '16, 22:07) immachon

Does help? That's a fork that I created in September with some batch file changes:

(there have been commits to osmosis since which this doesn't incorporate BTW)

(15 Jan '16, 22:29) SomeoneElse ♦

I also have this problem, I had a hard drive crash, came to reinstall and downloaded all the latest zips.

running osmosis came up with the error "Could not find or load main class org.codehaus.classworlds.Launcher"

I went for an older version and it came up with a different error, strange

So then I downloaded the zips that "SomeoneElse" suggested and hey presto the error disappeared. so I then cleaned out the directory and copied in the new bin from SomeoneElse, and the error reappeared. getting even stranger.

So then I cleaned out the directory again, put in the latest release, and the error was still there, so then I copied in the bin from SomeoneELse and the error disappears, quite bizarre.

(03 Feb '16, 11:54) Rossendale Gary
  1. Download the osmosis-0.48.3.tgz and extract Link to osmosis-0.48.3.tgz
  2. Then download osmosis-master Link to Osmosis-master. Then place the files inside osmosis-0.48.3 inside master file. It was lacking the plexus-classworlds-2.5.2.jar file.
  3. Also, when giving Java location make sure you add something like this : IF "%JAVACMD%"=="" set JAVACMD="C:\\"Program Files"\Java\jre1.8.0_301\bin\java"
permanent link

answered 10 Sep '21, 10:47

Madara's gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 15 Aug '15, 21:08

question was seen: 19,597 times

last updated: 10 Sep '21, 10:47

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum