We are facing problem with the setup.php file. Can any one has any way to overcome this error ?

    /public_html/Nominatim]# ./utils/setup.php --osm-file india-latest.osm.pbf --all [--osm2pgsql-cache 18000] 2>&1 | tee setup.log 
Warning: require_once(DB.php): failed to open stream: No such file or directory in /home/xxxxxxx/public_html/Nominatim/lib/db.php on line 2

Fatal error: require_once(): Failed opening required 'DB.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/xxxxxxx/public_html/Nominatim/lib/db.php on line 2


asked 31 Jul '15, 08:06

arj123's gravatar image

accept rate: 0%

It seems like you sure you are calling setup.php wrong.

--osm2pgsql-cache is an optional parameter. Either remove it completely or leave it there but remove the square brackets []. They are not part of the parameter but indicate only that this parameter is optional.

permanent link

answered 31 Jul '15, 08:12

scai's gravatar image

scai ♦
accept rate: 23%

edited 31 Jul '15, 08:13

Thanks @scai, so instead of ./utils/setup.php --osm-file <your data="" file=""> --all [--osm2pgsql-cache 24000] 2>&1 | tee setup.log I have to use ./utils/setup.php --osm-file <your data="" file=""> --all --osm2pgsql-cache 24000 2>&1 | tee setup.log ?

(31 Jul '15, 08:19) arj123

Yes, exactly :) Ideally you should adapt the size of the cache to your environment.

(31 Jul '15, 08:49) scai ♦

thank you.

(31 Jul '15, 09:16) arj123
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 31 Jul '15, 08:06

question was seen: 2,116 times

last updated: 31 Jul '15, 09:21

powered by OSQA