NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

My understanding is that MapQuest Open uses OSM data only, however, my edits in OSM from about 72 hours ago are still not seen in MapQuest Open.

Does anyone know how long it takes until my updates will it make into MapQuest Open?

asked 30 Mar '15, 21:19

bardu55's gravatar image

accept rate: 0%

edited 30 Mar '15, 22:10

aseerel4c26's gravatar image

aseerel4c26 ♦

My edit from about 4 days ago shows up in MapQuest Open already (high zoom levels).

Keep in mind that …

  • some feature classes (tags) may not be rendered by MapQuest,
  • you may need to circumvent your browser's cache,
  • only a request to MapQuest triggers a re-rendering, so you may need to reload again (without cache).
  • In general, see also
permanent link

answered 30 Mar '15, 22:08

aseerel4c26's gravatar image

aseerel4c26 ♦
accept rate: 18%

edited 30 Mar '15, 22:10

After my edits in OSM I have forced a re-render of a tile by loading just the tile image and then appending /dirty to the URL and also cleared browser cache when requesting open MapQuest. Since my edits are for a remote location in Northern Canada it might be that this region gets not frequently updated?

(30 Mar '15, 22:24) bardu55

@bardu55: everything could be. MapQuest is a completely separate company, I do not know their tile updating policy. Could you please mention a link to one of your edits/location?

(31 Mar '15, 00:24) aseerel4c26 ♦
(31 Mar '15, 00:31) bardu55

I cannot see your edits reflected in the MapQuest tiles, too. I would just wait more. Sorry, I do not know their schedule and did not find it by a quick search. It could be possible that you need to wait up to a month, and I was just lucky to edit right before an update cycle (for my region). I would expect about a week delay.

btw: the /dirty and /status seems to not work for the MapQuest tiles (at least there is no adequate response like there is for tiles).

(31 Mar '15, 00:48) aseerel4c26 ♦

If I go to and search for "carcross, yt, canada" and zoom in my edits are not shown as you have confirmed. The funny thing is if I click on "EDIT" potlatch opens in a new tab with my edits shown an the map.

(31 Mar '15, 17:55) bardu55

@bardu55: this is as expected and because the editor accesses the raw data – which is updated as soon as you upload/save an edit.

(31 Mar '15, 18:31) aseerel4c26 ♦

@aseerel4c26: I see, danke!

(31 Mar '15, 18:39) bardu55

FWIW: my edit from 16 minutes ago (in Germany) is showing up already on the "MapQuest Open" tiles. Quite fast! Your edits at Carcross are still not shown. :-( But there is not really anything we can do. You can try to contact Mapquest and ask what is going on there or if it could be made updating faster in Canada …

(05 Apr '15, 03:09) aseerel4c26 ♦

@aseerel4c26: Thanks, I have contacted MapQuest and I'm awaiting there response.

(06 Apr '15, 20:21) bardu55
showing 5 of 9 show 4 more comments

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 30 Mar '15, 21:19

question was seen: 3,897 times

last updated: 06 Apr '15, 20:21

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum