NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Hi folks,

I have been running a tileserver, which has been setup using this switch2osm manual on my old machine at home. It serves custom-style tiles for Berlin and it runs OK. I would like to change the region served and updated by mod_tile /osmosis on my test server from Berlin to e.g. Paris or Bavaria in one go.

Hence, I would not like the automatic expiry process (sudo -u www-data /usr/bin/openstreetmap-tiles-update-expire) to expire and delete my tiles. Rather I would like to quickly delete all tiles in the default tile directory and reset the expiry mechanism once I have updated the gisdatabase using osm2pgsql. I reckon this saves my weak old machine some time.

Does anyone know how to do this or has anyone even done this so far?

To be honest, I have already tried to do so and ended up being unable to update my new tileset, i.e. I am mainly looking for a way to reset the update mechanism, so that I don´t have to reinstall everything...

Thanks in advance!

asked 24 Mar '15, 16:04

V_T_'s gravatar image

accept rate: 0%

rm -r of the directory with the tiles

permanent link

answered 24 Mar '15, 16:19

SimonPoole's gravatar image

SimonPoole ♦
accept rate: 18%

Thank you, Simon,

this removes all my tiles.

In fact, I had already done so, but it does not solve my problem.

Let me explain a bit more:

I cannot remember to have done so but I must have deleted the dirty_tiles-folder as well. Whenever I run the tiles-update-expire script again it throws an error telling me that removing /var/lib/mod_tile/dirty_tiles.4900 (or the like) failed because such a file or directory could not be found.

How can I reset the update mechanism ?

(24 Mar '15, 17:18) V_T_

does /var/lib/mod_tile still exist?

(24 Mar '15, 18:03) SimonPoole ♦

Yes, it does.

(24 Mar '15, 18:55) V_T_

IMHO there is no "dirty_tiles" folder so this sounds slightly mysterious, are you sure that the permissions for the directories are still ok (typically owned by www-data, but your setup might vary).

(25 Mar '15, 10:48) SimonPoole ♦

Permissions shouldn´t have changed, but I´ll check this. If it falis, I will have a look at my backups. Ín case I have stored the tile directory I will try to restore it.

(25 Mar '15, 11:35) V_T_

Well, it seems as if I haven`t kept any backups for /var/lib/ . That means I am stuck at this point. Has anyone had any ideas ?

(26 Mar '15, 15:39) V_T_
showing 5 of 6 show 1 more comments

The whole confusion about my broken update mechanism and a missing 'dirty tiles' directory had been kicked off by me disregarding one important point in the referenced switch2osm manual - and SimonPoole was running in the right direction by argueing about missing permissions: I should have run the postgis permissions script, e.g.

sudo /usr/bin/ gis www-data

, on the database...

After doing so, all spooky dirty-tiles messages vanished and I can now change the served region as I like, including a proper updates-and-expiry mechanism. See also here

Thanks anyway for your headaches.

permanent link

answered 07 Apr '15, 21:59

V_T_'s gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 24 Mar '15, 16:04

question was seen: 4,211 times

last updated: 07 Apr '15, 21:59

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum