NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum


I've tried both OSMTracker and OpenGPSTracker for Android to generate gpx files. On opening them with josm version 3966-1 I cannot see any waypoints, just the grey line of my track which is apparently uneditable.

Here a sample of my gpx file:

<gpx version="1.1" creator="" xsi:schemalocation="" xmlns="" xmlns:xsi="" xmlns:gpx10="" xmlns:ogt10=""> <metadata> <time>2011-03-01T14:17:31Z</time> </metadata> <trk> <name>Track 2011-03-01 15:17</name> <trkseg> <trkpt lat="47.6107058" lon="10.6137722"> <ele>863.2999877929688</ele> <time>2011-03-01T14:17:36Z</time> <extensions> <gpx10:speed>1.1180340051651</gpx10:speed> <ogt10:accuracy>13.0</ogt10:accuracy> <gpx10:course>359.5</gpx10:course></extensions> </trkpt> . . .

asked 27 Mar '11, 20:47

toad's gravatar image

accept rate: 0%

If i remember right the OSMTracker generates two different files for waypoints and trackspoints, like YYYYMMDD_HHMMSS-wp.gpx and YYYYMMDD_HHMMSS-tp.gpx. Are you sure you haven't missed to transfer and open the wp.gpx-file in JOSM?

Apparently the gpx-file above has no waypoints because there are no wpt-entries in it.

Generally there is no problem to have both trackpoints and waypoints in the same gpx-file, but it's convenient to have them separated because then you can toggle them individually in JOSM.

permanent link

answered 27 Mar '11, 21:28

gnurk's gravatar image

accept rate: 15%

edited 27 Mar '11, 21:30

JOSM creates separate layers for track and waypoints when reading in a GPX file containing both. It does that for me anyway.

(28 Mar '11, 22:19) tongro

I don't know Open GPS Tracker, but regarding editing GPS traces in JOSM, it can be done. Right-click the GPX trace layer, select "convert to data layer", and the trace can now be edited. To convert it back to GPX, right-click the layer and select either "convert to GPX" or "export to GPX".

permanent link

answered 28 Mar '11, 22:28

tongro's gravatar image

accept rate: 0%

Tongro, you got the gist of what I was trying to do and say - many thanks!

I remember trying that option before and shying away from it because of the warning it gives. This time I ignored it and, weyhey, it worked :)

(28 Mar '11, 22:44) toad

Thank you for your quick answer.

Here is what I do: - stop tracking - select "share track" - send it to my email address

I've checked settings of both applications but do not see any reference to "waypoints" as such apart from how often I want to log my position. I double checked the files on my SD card and none of them have waypoints, only trackpoints!?

permanent link

answered 27 Mar '11, 21:58

toad's gravatar image

accept rate: 0%

I've never used Open GPS tracker, but from the screen shots at i guess that the Make Note-button is the one that creates waypoints. Have you used that button, or why do you expect some waypoints to be in the export?

(27 Mar '11, 22:39) gnurk

Take your tcx file from the garmin and convert it to gpx using and then it should load properly in JOSM

permanent link

answered 24 Apr '11, 19:57

Hotbelgo's gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 27 Mar '11, 20:47

question was seen: 6,394 times

last updated: 24 Apr '11, 19:57

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum