NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Hello all, I'm new to Openstreetmap. A friend suggested I try it. But I haven't been able to even see any map at all on the web site! I just get a gray rectangle where the map is supposed to be. I get a few tool buttons on the upper right and an indication of the scale in the lower left corner, a search window in the upper left corner and a copyright notice in the lower right one, plus a command bar over the map area, but no map. If I click on the + or - buttons, the scale indication changes, but still there is no map. I had a look at the internet traffic, and I see that the site only transfers a small burst of data to me when I open the page, and nothing at all when I change the scale. Obviously something is wrong and no map data at all gets transmitted to me.

But what can be wrong? Am I missing some plug-in, or anything else?

I know the problem is on my side, but I need help fixing it. I have the same problem with images embedded in a few other web sites, typically maps too. So there must be some kind of traffic my system isn't handling correctly, or perhaps my ISP is blocking, but I have no idea what it is! Most web sites work perfectly for me, with all of their contents.

I'm using Firefox 12.0 on Windows XP.


asked 20 Feb '15, 21:05

Carozwei's gravatar image

accept rate: 0%

edited 23 Feb '15, 00:49

aseerel4c26's gravatar image

aseerel4c26 ♦

this is not a fix, but a workaround: since you want to contribute to OSM you need an editor anyway: Download and try our editor JOSM. For the start you could use it to just view the current OSM maps (background menu → Mapnik). Maybe it will work (it is a Java-based stand-alone program - not inside a browser).

(26 Feb '15, 01:26) aseerel4c26 ♦

I was running Firefox 30.something and I thought that was old. And Windows XP is no longer supported by Microsoft and is very insecure. I hope you don't do anything on that computer that involve personal or financial information as you are just begging to be hacked.

If your machine supports it, you should update your operating system. I don't know what the latest Firefox version is that will run on XP but at the least you should update whatever it is. For what it is worth, the much later version of Firefox I am using seems to work on properly.

permanent link

answered 20 Feb '15, 21:23

n76's gravatar image

accept rate: 17%

Ooops! It came as a surprise to me that Firefox 12.0 is so outdated. I was using version 6.0 until just a few weeks ago! That one dates from 2011, and everything worked just fine, except for certain images... That's why on January 4th this year I updated Firefox, using the update function of the software, and it installed version 12.0, which I assumed to be the current version at that moment! Needless to say, those specific images still didn't work.

Well, now I updated Firefox again, and this time it installed version 35.0.1. It has some cosmetic changes, a very few new functions, and surely a lot of internal changes and bugfixes - but I still can't see any map on! It's the same as before, a gray rectangle. So it clearly isn't a problem of the browser being outdated.

Regarding XP, I know it's not secure, but then, is ANY Windows version secure? I doubt it! I don't have anything sensitive on this computer, anyway, and I have a full backup which I update frequently. That should be safe enough. My reasons for keeping XP are two: One is that newer Windows versions are even more problematic when it comes to run extremely old software (DOS software, actually, dating from the 1980's), and I need that old software in order to use about $20,000 worth of lab equipment which I just don't want to throw away and replace in order to be able to use a newer Windows version! So it would mean adding yet another PC, and I'm running out of space. And the other reason: Windows costs money! I'm tired to be sold a product, and then be told by the manufacturer to throw it away and buy a new one, because the old one was buggy and insecure.

The question now is: Are the maps not showing because Windows XP lacks something they need? I find that unlikely. If it's not XP's fault, what else can be wrong?

(20 Feb '15, 22:59) Carozwei

A couple of questions:

1) Where in the world are you? The map tiles that you should see will come from a location that varies depends on where you are (for example, if you're in the USA you'll see tiles from a server in the USA).

2) Does this URL (of a single map tile) show anything:

(20 Feb '15, 23:06) SomeoneElse ♦

I'm in Chile. Is there a server in Chile, or should I be getting the tiles from some other server? Can I try other servers, in some way?

And YES, I can see that single map tile showing Clipstone perfectly well!

(22 Feb '15, 14:32) Carozwei

@Carozwei: hmm, strange. Does show a usable map for you?

Do you use any "internet security" whatever blocker programs? Personal Firewall? Firefox addons? Could you try with another browser or under a different user account (windows) / user profile (Firefox)?

(22 Feb '15, 16:32) aseerel4c26 ♦

I just checked, and I don't see a map on the German site either. But there is a difference: I don't even get the gray rectangle there! The map area is white instead of gray.

Yes, I'm using a Firewall (ZoneAlarm). I don't want to eliminate that one, nor open it up far and wide, so I would need to know what exactly I need to allow. For example, I have ZoneAlarm blocking all programs that try to act as servers.

I have a single Firefox addon, an ad blocker.

I tried accessing OSM from Internet Explorer, which doesn't have the ad blocker, and still it didn't work.

(22 Feb '15, 16:54) Carozwei

@Carozwei: I guess you only have IE8 on your WinXP? does not work (currently at least.

You could try with e.g. a Chromium-based browser like Iron or Opera … but a fresh/clean Firefox profile would also be okay. Zone Alarm should not be a problem unless you have set it up to block, for example, specific requests. Check its log. Similarly with an adblocker – if you configure it to block *tile* then you will not see a map. Also it might be interesting if it works on other computers in the same network.

(22 Feb '15, 17:42) aseerel4c26 ♦

@Carozwei: do other map styles/"layers" (top right menu) on .de or .org work?

(22 Feb '15, 17:44) aseerel4c26 ♦

I have set up ZoneAlarm to block most programs except those I want to access the internet. This is to improve security and to avoid useless traffic - I have to pay per traffic (about $30 per gigabyte).

The ZA log shows mostly unrelated blocked traffic. The only entries I see that MIGHT be related are two incoming packets, from my ISP's name server to svchost.exe. I have set up ZoneAlarm to stop SVCHOST from acting as server, but it is allowed normal internet access.

The adblocker has its standard configuration.

I have no other networked computers.

Other styles don't work either.

(22 Feb '15, 22:51) Carozwei

@Carozwei: Ouch, that's expensive. It is really hard to try to debug from remote. I assume the website should run without problems on WinWP with Firefox, so I do not really know what else can be wrong (and can be easily tested). The only thing left is: try in a new browser / user profile (without that adblocker) or just switch it off temporarily.

last try: try with skobbler's OSM-based map (which shows many osm-based maps - mostly as service for our contributors not for end users).

(22 Feb '15, 23:36) aseerel4c26 ♦
showing 5 of 9 show 4 more comments

oh, I just realized that you wrote: "I know the problem is on my side, but I need help fixing it. I have the same problem with images embedded in a few other web sites, typically maps too."

Hmm, okay,

  1. is JavaScript enabled? (likely it is, otherwise not "Most web sites work perfectly for me")
  2. try a https (via SSL/TLS) access: . That prevents your ISP or any "security" software (which is not in your browser) from altering the content (assuming that you do not have installed any fake root certificates in your browser).

Am am sorry that you have such a bad experience on your first try to access OSM. OSM is more than just those web maps. Based on our data are also for example GPS devices maps, smartphone apps, … That might be another option if you have such a device (many questions here exist how to use OSM on other devices, just search or ask a new one or look at Software).

Addition: I have tried with an WinXP computer with Firefox 35.0.1: works (even the new routing). With IE8 it does not work (as expected - I just see some messed up controls but no map). With an old Iron 16 (chromium-based) it worked too.

permanent link

answered 22 Feb '15, 23:52

aseerel4c26's gravatar image

aseerel4c26 ♦
accept rate: 18%

edited 23 Feb '15, 20:07

I tried, and it's the same. Doesn't work for me.

In the old browser version, I had Javascript enabled. In the new version, there isn't even a configuration option to disable it! It could only be disabled by loading an add-on.

Flash is disabled here, and some non-essential Windows services. Does this site perhaps need Flash?

I tried HTTPS access. No change.

I do have a laptop PC and an Android tablet in addition to this desktop PC, but only the desktop has internet access.

My intentions are getting maps of my area for my GPS (Garmin eTrex Vista C), and contributing my data.

(23 Feb '15, 18:22) Carozwei

@Carozwei: To test JavaScript, just click my link: the page will tell you if you have it or not. Well, you have it enabled, otherwise you could not even add a "comment" here.

No, Flash is only needed for our "Potlatch" editors (there are also non-Flash editors, btw). But Flash is not needed to view the maps I've linked to (I do not have Flash myself in my Firefox).

(23 Feb '15, 19:16) aseerel4c26 ♦

@Carozwei: Okay, for Garmin maps, see our wiki page with pre-made Garmin maps, or one of the many garmin questions here. I personally suggest you start with a map from (select "Chile", "Download map now!" (80MB), download the file. It is possible to also only download a part of Chile (smaller download), but that requires the map on that page to work (I can assist you by mail if that map does not work too)

(23 Feb '15, 19:16) aseerel4c26 ♦

@Carozwei: Doing anything useful with the tablet will be hard without Internet access.

A very simple, easy, very low internet traffic option is to contribute/upload your GPS traces/tracks ("active track") to help other OSM mappers to trace the streets/paths. Of course, still someone needs to do it. Again, if you need help with this, please ask a new question so we can focus on the strange map display problem here.

(23 Feb '15, 19:16) aseerel4c26 ♦

I had the same problem. I found that my Adblock Plus application was blocking the map. Whitelisting OSM solved the problem.

permanent link

answered 15 Jul '19, 10:22

deipnosophista's gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 20 Feb '15, 21:05

question was seen: 20,120 times

last updated: 15 Jul '19, 10:22

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum