NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Hello. I downloaded the pre-configured selection for Thailand and expanded the .zip to reveal two folders, an .mdx file, and an .xml file.

The folder Product1 contains a number of sub-folders with 5 file types in all but 1 of them, and one .tbd file. The folder named _mdr holds an .mdr file and an .srt file

The instructions for importing the maps on the Basecamp wiki suggest that double clicking the .gmapi file will invoke MapManager to import the maps ready for BaseCamp. I am at a loss to where the .gmapi file is - my Mac is also convinced there are none here...

I tried "Open with" MapManager for the non-binary files I could find with no success.

I concurrently downloaded the OSM generic file to copy to the card in my Garmin, but need the detailed maps on my Mac to plan my routes. The global basemap does not have any usable detail for Thailand.

Any and all assistance would be great - I am currently stuck with GoogleMaps and a 2008 Garmin map for SE Asia which don't talk to each other...

Many thanks.

asked 22 Jan '15, 10:56

DualSportBiker's gravatar image

accept rate: 0%


Can you explain where you downloaded your map files from? This isn't a service offered on, so they must have come from a 3rd party site.

(22 Jan '15, 10:58) Jonathan Ben...

I got them from

There is an automated selector based on country name.

(22 Jan '15, 13:16) DualSportBiker


Up till I upgraded to el Capitan, i was able to install maps to basecamp on my mac. I tried all the aboveanswers[moderator edit after conversion to comment], but now i'm unable to install the OSM maps on my computer. I wish someone could help,



(21 Apr '16, 14:01) Steno

I was redirected here. Have the same problem, my computer treats the .gmap as a folder and opens it, rather than installing. I also tried renaming to .gmapi but the map doesn't appear in basecamp

(21 Apr '16, 20:12) Steno

I have had the same battle for years. Every time I take a 'trip' (yearly) I stress because I cannot load maps from OSM to garmin with mac. I even stumbled onto a OSM thread about my case (my screenshot) from oct 2008...I recognize the setup. STILL can't do it correctly and spend more time than my vacations trying to get it to work. Pretty sad. I can get the gmap, but not the .img...hit and miss. I am about ready to give up on maps and just use my topo that i have.

did you find a solution?

(20 Aug '16, 15:56) Rangerricksclan

Hi, after many tries this is what worked for me: download maps from: open terminal on mac and type:

cd ~/Downloads
unzip <downloaded_map>.zip
cd /Applications/Garmin\\
sudo mv ~/Downloads/<downloaded_map>.gmap .

the last command end with dot (means current directory) and will prompt for password. Now you can open basecamp with the map selected. If it is not selected, then you can pick it from the Maps menu.

permanent link

answered 09 Feb '17, 09:26

pete911's gravatar image

accept rate: 0%

edited 10 Apr '17, 14:05


This is what worked for me in the end. Thanks a bunch!

(21 Mar '18, 15:32) krisse

OK. After file is unzipped, create a new folder. Give it the same name as GMAP folder. Move Gmap folder inside new folder. Then add .gmapi to the name of new folder. That will change it to a gmapi file. Double click it and install.

permanent link

answered 15 Feb '15, 15:06

Trint%20Cole's gravatar image

Trint Cole
accept rate: 0%


This is the answer that worked for me. The new folder can't have an extension in the name because you won't be able to add the .gmap folder if it has one. After putting the .gmap folder into the new folder you created, give that new folder the same name as the .gmap folder but with .gmapi as the extension. As Trint Cole describes :-)

(09 Jun '15, 18:28) chethrington

The solution to rename the file extension to .gmapi didn't work for me either so here's what did:

  1. download and extract the "" file
  2. download and install Garmin MapManager here:
  3. open MapManager and select "File/Install Map..." and open the unzipped map file (*.gmap)
  4. open BaseCamp and select "Maps/OSM generic routable"
permanent link

answered 07 Apr '16, 04:41

ShaolinMasterMind's gravatar image

accept rate: 0%

You need to download the "osm generic" and this will extract to the file "OSM generic routable(THA_19-01-2015).gmap" and that when double-clicked will install on the mac using Garmin I think and Basecamp on the Mac will load it fine. It worked for me ok.
You may have downloaded the Windows or Linux file by mistake or got amongst the "Nullsoft Scriptable Installer script used to create the BaseCamp/MapSource installer." which is probably a Windows thing? file list

permanent link

answered 22 Jan '15, 14:29

nevw's gravatar image

accept rate: 9%

edited 21 Apr '16, 20:00

aseerel4c26's gravatar image

aseerel4c26 ♦


Apple finder presents the .gmap as a folder, and allows it to be opened. MapManager also recognises it and imports it without issue.

Many thanks!

permanent link

answered 23 Jan '15, 06:42

DualSportBiker's gravatar image

accept rate: 0%

I am using el capitain. I have followed the renaming new folders advice above, and still nothing good. Finder simply opens the new folder.gmapi when I double click, Basecamp browser launched from 'Import into My Collections' also simply opens the folder and leaves the 'import' button greyed out. Should I be using a different command from within Basecamp? Do I need anythign else installed on the MAC to make a double click in Finder work? My maps were created by, and I am using the

(16 Feb '16, 18:20) NeilUK

I finally found a solution. Actually still cannot import directly in basecamp as i used to but......!!!!!! After about a year of no more new OSM maps on my basecamp (mac osx el capitan), I just installed a new map for the first time again. :-) the solution for me is: don't import into basecamp (I stopped trying, none of the above helped me and couldn't find a solution). Instead: paste the map directly into the gps, then connect the gps to the computer and basecamp imports the map from the gps.

Hope this helps anyone who still struggles.


permanent link

answered 18 Sep '16, 06:58

Steno's gravatar image

accept rate: 0%

I know the original question is quite old but I'll update my working solution here just in case someone came across the question like me.

MacOS Mojave 10.14.2 Basecamp 10.4.0

  1. Grab your map from - I downloaded the ""
  2. Unzip the file. You should get a folder "OSM generic routable new <something>.gmap"
  3. Use Finder to locate your Application folder.
  4. Hold Ctrl- click on the Basecamp app icon. Select "Show Package Contents"
  5. "Contents" folder should show up. Select it and you will find a whole lot of files and folders.
  6. Drag your "OSM generic routable new <something>.gmap" into "Resources" folder.
  7. Start (or Restart) your Basecamp and your OSM map should show up.

Hope this helps!

permanent link

answered 23 Dec '18, 13:20

NateeT's gravatar image

accept rate: 0%

edited 24 Dec '18, 14:27

I think this is the same as the current top answer but you are using the GUI (maybe easier for some people) instead of the command line/terminal. Thanks!

(24 Dec '18, 09:23) aseerel4c26 ♦

You are absolutely right Natee T!!!!!!!!! After a lot of trying this method works just like this!!!!! GREAT!!!!!!! Thank you!!!!!!!!!!!!

permanent link

answered 29 Jun '19, 03:19

Helder1971's gravatar image

accept rate: 0%

the answer is simple:

add the .gmap fil to the resources folder in the basecamp app. It is what the code shared in this thhread does.

  1. Close basecamp
  2. go to applications.
  3. right click on basecamp
  4. select show package contents
  5. navigate to the resources folder
  6. Paste the .gmap folder in there
  7. launch basecamp
  8. profit
permanent link

answered 19 Sep '21, 22:38

keppes's gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 22 Jan '15, 10:56

question was seen: 76,361 times

last updated: 19 Sep '21, 22:38

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum