Hi There:

I am using the paid version of OpenStreetMap's mobile app, "OpenMaps," on an iPhone 5.

Among the settings there is an option to change the map format to different tiles.

One is "MapQuest Open Aerial" tiles. When I select this, the tiles are greyed out with the comment, "Map tile not available."

The URL link to this tile is: http://oatile1.mqcdn.com/naip/<zoom>/<x>/<y>.png

The current link on the MapQuest website is:

http://otile1.mqcdn.com/tiles/1.0.0/sat

... Since the app tells me I need the zoom xy string, I have modified this link to:

http://otile1.mqcdn.com/tiles/1.0.0/sat/<zoom>/<x>/<y>.png

... Which still doesn't work.

Does anyone know the correct URL link to make these tiles appear? I would like to use the satellite aerial imagery.

I have contacted MapQuest with the same question, but have not heard back yet.

Thanks very much,

waynrayn

asked 14 Jan '15, 19:41

waynrayn's gravatar image

waynrayn
11112
accept rate: 0%

edited 15 Jan '15, 00:14

aseerel4c26's gravatar image

aseerel4c26 ♦
32.2k16239552

2

Just for info, OpenStreetMap does not have a mobile app, though lots of companies do create apps that use OpenStreetMap data.

(14 Jan '15, 19:56) SomeoneElse ♦

One more question - what zoom level and where are you trying to download?

http://oatile1.mqcdn.com/tiles/1.0.0/sat/8/127/83.png

works for me for example, but there aren't detailed tiles of the UK there.

You'll also want to check Mapquest's tiles' terms of use, which I believe are:

http://developer.mapquest.com/web/info/terms-of-use

See also

http://developer.mapquest.com/web/products/open/map

(14 Jan '15, 20:13) SomeoneElse ♦

Hi Someone Else:

In answer to your question, the OpenMaps app I use only has one setting for each tile URL. This setting is "2X Zoom," and it is either on or off. There are no other options.

My modified link does seem to work, if I move down to the States, as alester pointed out. I confirmed this. So I guess this particular tile just isn't covering Vancouver Island yet.

Regards,

waynrayn

(14 Jan '15, 21:02) waynrayn

I already had that app installed, so I tried modifying the URL as you described and it worked just fine.

When you try it and it "still doesn't work", in what way? Do you still see tiles that say "Map tile not available", or do you see tiles with a crossed-out camera? The latter is what you see if the tiles are successfully being downloaded, but there's no imagery available for that area and/or at that zoom. Keep in mind that the MapQuest Open Aerial coverage at the high-zoom levels isn't global. For my area in southwest Canada, there's only imagery at fairly low zooms. If you want to check if your configuration is working, try zooming in on a major city in the United States.

permanent link

answered 14 Jan '15, 20:02

alester's gravatar image

alester
5.3k25578
accept rate: 29%

Oops...

The OpenStreetMap help team just let me know that this is apparently not their app. My bad.

Still, if anyone might happen to know the correct URL for MapQuest Open Aerial tiles, it would really help.

Thanks very much,

waynrayn

(14 Jan '15, 20:01) waynrayn

Hi alester:

Thanks for your response.

You are correct. I am in Victoria, on Vancouver Island in BC. Using my modified link, I moved out of this area and down to the States, and satellite imagery appeared. I see however that this does not seem to superimpose trails of any kind, so obviously it has nothing to do with OpenSteetMaps, which kind of defeats the purpose. I was hoping to have map trails superimposed over the satellite imagery. I'll stay with OpenStreetMaps data, which provides excellent information on trails.

Regards,

waynrayn

(14 Jan '15, 20:20) waynrayn
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×28
×1
×1

question asked: 14 Jan '15, 19:41

question was seen: 5,280 times

last updated: 15 Jan '15, 00:14

powered by OSQA