Hi everybody,

I am having some problems to install Osmosis in my Windows 7 64 bits. I downloaded the last versión available (0.47.1 in http://bretth.dev.openstreetmap.org/osmosis-build/osmosis-latest.zip). I followed the install guide (http://wiki.openstreetmap.org/wiki/Osmosis/Quick_Install_(Windows) and http://learnosm.org/en/osm-data/osmosis/#install-osmosis).

I also changed the java issues as It is recommended in the guide:

  • Find the java application (exe file)
  • it's probably in C:\Program Files (x86)\Java\jre6\bin.
  • Edit C:\Program Files (x86)\osmosis\bin\osmosis.bat
  • Find the line about 3/4 of the way down that sets JAVACMD and change it to:
  • IF "%JAVACMD%"=="" set JAVACMD="C:\Program Files (x86)\Java\jre7\bin\java"
  • You may also have to change the line near the end that sets EXEC and put double quotes before and after %JAVACMD%*

When I check if osmosis is working through executing it in cmd, it doesn´t work: c:\osmosis\bin\osmosis or directly from c:\ --> "Java" is not recognize as internal or external command, programm or ...

The weird thing is that I also installed osmosis in a virtual machine with xp and there It does work. The problem is that It works really really slow.

Does anybody know how to fix this problem in Windows 7?

Thanks in advanced, Fermin

asked 08 Jan '15, 11:54

frose's gravatar image

frose
100338
accept rate: 0%

edited 08 Jan '15, 11:55


I'm using Osmosis on Windows 8 64 bit, and am using

IF "%JAVACMD%"=="" set JAVACMD=C:\Windows\SysWOW64\java

I don't remember changing anything else (though admit I seem to be a couple of versions behind at the moment).

Edit: If you just type JAVA at the command prompt, does it run?

permanent link

answered 08 Jan '15, 12:10

EdLoach's gravatar image

EdLoach ♦
17.8k14145258
accept rate: 23%

edited 08 Jan '15, 12:12

2

Hi Ed,

You were right. I don´t know why but my java worked for several programms but not at the command prompt. I´ve updated the java versión and now It works everywhere although I have to close-open the command prompt window after each command because it seems only to allow one command each time. I think I could overcome this little problem.

Thanks!!!

(08 Jan '15, 14:20) frose

Interestingly I've just seen (on 64-bit Windows 7) an Oracle Java update delete the "SysWOW64" 32-bit version, though what I presume is a 32-bit version remains in "C:\Program Files (x86)\Java\jre1.8.0_40\bin".

So if you absolutely need a 32-bit version, and the "SysWOW64" one is missing, you know where to look...

(25 Mar '15, 14:36) SomeoneElse ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×216
×19
×2

question asked: 08 Jan '15, 11:54

question was seen: 4,077 times

last updated: 25 Mar '15, 14:36

powered by OSQA