I have been struggling to get OSM maps working on my Garmin nuvi 1490 GPS.

I downloaded the maps for the area I am interested in from the website http://garmin.openstreetmap.nl/ (gmapsupp.img file). I connected the device to the computer. The original maps (North America) are in the folder ".System". The GarminDevice.xml in Garmin folder in the device shows that I can put supplementary maps in Map folder. So I created the Map folder and put the img file there.

When I boot up the device, after "loading maps..." it only shows the pre-loaded maps. I went to tools->settings->Map->Info and I see both OSM and preloaded maps there. I unselected the preloaded maps and selected the OSM maps. But, I still dont see the OSM maps on the device!!!

Can someone point me to what I am doing incorrectly?

asked 17 Oct '14, 09:10

manij's gravatar image

manij
16112
accept rate: 0%

closed 27 Oct '14, 11:41

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551

Which was "the website"? There are lots of different websites offering OSM-based Garmin maps. Do you really mean "gpssupp.img" as the file name?

(17 Oct '14, 09:21) SomeoneElse ♦
1

My apologies -- the file name is gmapsupp.img. I downloaded this from http://garmin.openstreetmap.nl/

Changed the question to reflect the same

(17 Oct '14, 09:25) manij

What do you see instead? Still the pre-installed map or nothing? Are you in an area covered by the OSM map you downloaded?

(17 Oct '14, 10:43) scai ♦

Indeed. I still see the pre-installed maps. I am in the area covered by the OSM map (India). It shows me the last location in North America when the GPS was switched off.. It also keeps trying to acquire sattelites.

If I give the longitude and latitude of India, the GPS shows that I am in the middle of the ocean. Basically, I think the OSM map is not loaded.

(17 Oct '14, 10:58) manij

@manij: are you sure that you entered the coordinates correctly (same format as you have the GPS device set to)? Or try to get a GPS position (that may take much longer than usual because you have moved that far away from your last position – also see your device's manual).

(17 Oct '14, 11:01) aseerel4c26 ♦

I will try to enter the coordinates again tonight and get back to you guys. What I had done is that I had gone to "http://gpx-poi.com/" and found out the latitude and longitude of my location in India. The GPS coordinates format was set to decimal degrees: h ddd.ddddd°

I will confirm this tonight though.

(17 Oct '14, 11:11) manij
2

I went to the logs. In the logs this is what I see there:

Boot BLK B0972-00 6.20 nuvi 1490 Boot Block Software Pass

X-loader B0972-00 6.20 nuvi 1490 X-Loader Software Pass

System B0972-00 6.20 nuvi 1490 System Software Pass

Basemap F0057-01 5.00 Worldwide Autoroute DEM Base 4779E900

Suppmap Erased

Suppmap1 ?????-?? 0.00 OSM generic routable new(IND_ 769D6545

PROM 1 D0322-10 20.11 CN North America NT 2011.20 9CD8FBE2 ...

(17 Oct '14, 13:34) manij
2

Ok. So what I said was incorrect about the maps not being loaded. As aseerel4c26 suspected, I was entering the coordinates incorrectly. If I enter the coordinates correctly, I am able to get to the OSM Bangalore maps. Although, in this case, the GPS seems to shutdown unexpectedly if I zoom in.. not sure why that is...

But when I swithch the unit on, it still shows me in North America. Perhaps this is just a matter of me waiting outside long enough for the satellites to see me?

(17 Oct '14, 17:05) manij
1

It doesn't surprise me that it takes a long time to get a lock if it thinks that it is in the wrong continent. Unlike a mobile phone, it doesn't know the time accurately until it's got signals from GPS satellites, and can't download ephemeris data.

(17 Oct '14, 17:13) SomeoneElse ♦
5

For posterity -- the maps have been installed properly on Garmin 1490. Everything seems to work well. The procedure listed is indeed the correct one. It was just a matter of waiting till the GPS "saw" the satellites.

(27 Oct '14, 05:53) manij
showing 5 of 10 show 5 more comments

The question has been closed for the following reason "Not an OSM-related problem. Solved: "It was just a matter of waiting till the GPS "saw" the satellites."" by aseerel4c26 27 Oct '14, 11:41


Your process seems to be okay for me. Not sure what the problem is (I do not own this device).

Maybe you could try to create the folder "Garmin" instead and put the .img file there (in the filesystem root(!)).

However, according to the device's entry at OSM_Map_On_Garmin/Mass_Storage_Mode your /Map folder is fine.

See also our wiki page OSM_Map_On_Garmin#Installing_the_map_onto_your_GPS.

permanent link

answered 17 Oct '14, 10:46

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551
accept rate: 17%

edited 17 Oct '14, 10:47

1

The Garmin folder already exists on the GPS. It contains a folder Lex_pkg (I will have to recheck if that is the name or not) and the GarminDevice.xml file. I had originally placed the img file there. When I do that, the maps dont show up in tools->settings->Map->Info

(17 Oct '14, 10:59) manij

I beleive that the 1490 will read .img files in either the /garmin or the /Map folder ( note upper case M is required) You device appears to be aware that there is a useable osm available and in the correct directory. Are you outside to receive the satellite signal - it won't find signals if you are under cover. :)

(17 Oct '14, 11:37) nevw
1

I am indeed outside to check for satellite signal. I have the img file in /Map folder.

(17 Oct '14, 14:14) manij

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×289
×28
×1

question asked: 17 Oct '14, 09:10

question was seen: 5,213 times

last updated: 27 Oct '14, 11:41

powered by OSQA