NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

When I use regular osm map editor (edit with iD (in browser)), the bing aerial imagery in the background is really old. But when I use the potlatch editor, bing aerial imagery is new. Why regular editor uses old version? please see the links below for the same area, notice the difference.


asked 29 Aug '14, 22:11

kavur's gravatar image

accept rate: 0%

edited 30 Aug '14, 12:49

aseerel4c26's gravatar image

aseerel4c26 ♦


I would suggest clearing your browser cache and comparing then again.

(29 Aug '14, 22:19) SimonPoole ♦

that's not the correct answer unfortunately. click the links and see the difference.

(29 Aug '14, 23:05) kavur

I can see the same car parked in the same place in the carpark at the left in both pictures:

alt text

alt text

(29 Aug '14, 23:20) SomeoneElse ♦

Find another computer and see how they compare. I can see no difference.

(29 Aug '14, 23:20) Wynndale

A side note: Please rather say "bing aerial imagery" instead of "bing maps" to prevent misunderstandings as are not allowed to use all parts of bing maps. See bing in our wiki.

(29 Aug '14, 23:24) aseerel4c26 ♦
2 I see these images in three different computers. It's not slightly different, it's completely different.

(29 Aug '14, 23:48) kavur

@kavur: thanks for those screenshots! Is it possible for you to find out the URLs of those images? Or even the IPs of the serving servers? Might be a bit technical … ;-)

(30 Aug '14, 12:40) aseerel4c26 ♦

@aseerel4c26: when i click the links in the question, i see these images. as for server ips i can do that if you tell me how to do it :)

(30 Aug '14, 13:02) kavur

Remote Address: Request URL: Request Method:GET Status Code:200 OK (from cache)

@aseerel4c26: would this help?

(30 Aug '14, 13:07) kavur

@kavur: I am just guessing/trying, maybe we find something odd or interesting. Yes, exactly. Best use a location where there are clear differences. Now compare or post URLs and IPs for the request from both editors. Maybe they are served by different servers. Maybe on is via http and one via https which magically makes a difference, I do not know. Whatever we find out, maybe, in the end, we cannot change it because the aerial imagery is served directly by microsoft. But let's see …

(30 Aug '14, 14:11) aseerel4c26 ♦

@aseerel4c26: these are header info for id and potlatch editors for the (almost) same area: for potlatch: Remote Address: Request URL: Request Method:GET Status Code:200 OK and for id: Remote Address: Request URL: Request Method:GET Status Code:200 OK hope it helps.

(30 Aug '14, 14:55) kavur

@kavur: Hmm, no, this last info is not really helpful. I meant that you look for those URLs. Those may be interesting.

Oh, and, could you please try to access iD also (as you do so too for potlatch2) without https? → see what happens then.

(30 Aug '14, 15:11) aseerel4c26 ♦

@aseerel4c26: i tried http instead of https, it didn't change.

in potlatch editor, under developer tools i can't see images. so i'm not sure what to do.

(30 Aug '14, 15:23) kavur

@kavur: could you please look up the URLs and IPs for the requests by both editors? That is my only idea.

(31 Aug '14, 00:11) aseerel4c26 ♦

@aseerel4c26: can you tell me how do i do that?

(31 Aug '14, 00:20) kavur

@aseerel4c26: i think i figured:

this is for id:

Remote Address: Request URL:

and this is for potlatch:

Remote Address: Request URL:

(31 Aug '14, 00:30) kavur
showing 5 of 16 show 11 more comments

Thanks for the info about the servers (from your comment):

I think I got it now: It seems you are served by a Akamai (this is a content distribution service which is apparently used by Microsoft) server from Cambridge ( (USA) and I by one from Switzerland (

The interesting part (I just hope that I did not make a stupid mistake somewhere):

I have circumvented DNS (via hosts file) and targeted my requests to the Cambridge server ( Observation: This server serves different images via HTTP respectively HTTPS! Tested with Here are screenshots with and without https, ctrl+f5 of course (see in log below: HTTP200 – not HTTP304): gif animation Cambridge.

Then I reverted my hosts file change (so I am back on via DNS): same, new, content via HTTP respectively HTTPS. gif animation Switzerland. Note the much faster timing than from Cambridge (that is the reason why usually the nearest server is assigned to you).

By the way: Others from near Cambridge or even the whole USA (those "others" who get assigned to this server by MS/Akamai's DNS system) should experience the same as you. As far as I know/guess all who commented here are not editing from the US.

What to do?

  • So in principle you should get the new images if you access via HTTP, I am not sure why it seems that you do not get the new images (judging from your comment above – maybe your browser cache? or does iD always use HTTPS for the bing aerial imagery even if accessed via HTTP?).
  • As a workaround you could use your hosts file to direct your requests to to the IP of the Switzerland server. Add the line to your hosts file. Note: apparently Chromium (which you seem to use) does not refresh its DNS cache by ctrl+F5. I used Firefox in my test. Chromium only obeyed the change in the hosts file after a restart.
  • Ask Microsoft to sync their CDN servers (whyever there is different content for HTTPS on this server …).
  • use HTTP Potlatch, get outside and have a look at the real world, wait, … ;-)
permanent link

answered 31 Aug '14, 01:41

aseerel4c26's gravatar image

aseerel4c26 ♦
accept rate: 18%

edited 31 Aug '14, 02:18


@aseerel4c26: thank you. it's good now :)

(04 Sep '14, 12:21) kavur

@kavur: do you mean that the problem (as described in your question) does not exist anymore? By doing nothing? Or did you change anything?

(04 Sep '14, 23:14) aseerel4c26 ♦

@aseerel4c26: yes, the problem has been solved. I can see same pictures in poth editors. I didn't do anything. I thought you fixed it.

(05 Sep '14, 00:20) kavur

@kavur: No, I did not do anything except investigating and writing this answer. Thanks for your comments!

(05 Sep '14, 00:24) aseerel4c26 ♦

I think they are the same the dates are the same, The car is it the same position and the shadows look the same to. in this slightly moved views. if you move south a little the brown patches in the vegetation are the same and the car in the car park to the SW is the same. Near by on the freeway two vehicles are passing each other in both editors which I think proves the images are at the same time.

permanent link

answered 30 Aug '14, 21:20

andy%20mackey's gravatar image

andy mackey
accept rate: 4%

edited 30 Aug '14, 21:57


@andy-mackey: obviously we see completely different stuff. when i click the first link (id), i see most of the houses aren't even there. they weren't built yet. the image is from 2007 most optimistically.

did you see the screenshots i posted in one of those comments?

(30 Aug '14, 23:25) kavur

Thanks kavur it must have been hard for you show that

(31 Aug '14, 08:28) andy mackey

Having looked into this today it seems to be (at least in my case) a parameter that iD sends to Bing Maps API, the whole thing is being discussed extensively here. iD sends pr=odbl to the API, if you remove this you will get the newest images. No idea what this parameter is or why it is supposed to do. An easy workaround for the time being is to go to the Backgrounds menu in iD and select Custom in the end. In the dialog that opens input https://ecn.t{switch:0,1,2,3}{u}.jpeg?g=1&n=z and click OK. If this does not work immediately try to refresh the page a few times.

permanent link

answered 29 Aug '22, 18:32

esteros's gravatar image

accept rate: 0%


You are responding in a thread from 2014. Everything you point out on the current issue has already been pointed out in the corresponding github issue.

(29 Aug '22, 18:55) SimonPoole ♦

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 29 Aug '14, 22:11

question was seen: 7,369 times

last updated: 29 Aug '22, 18:55

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum