NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I loaded an .img file on my garmin nuvi2460. The map is present on the gps and activated. When I zoom on an area covered, I only see some part of the map but not the full map. If I change the zoom level I will see more or less part with sometimes previously visible area which will disappear and others which will appear. The data seem to be present but not visible everywhere, since I can simulate a trip from one point to another even in invisible area. In the part where no information is displayed I can only see the path of the planned trip.

I checked the map using BaseCamp and I don't have any trouble, all data seem to be present.

Where is the problem coming from?

I tried to install an .img file of canada from "" and from "". Both appear in the same way.

asked 16 Aug '14, 16:09

gamapr's gravatar image

accept rate: 0%

Did this get solved. I have exactly the same problem with maps for Western Canada.

(29 May '20, 04:21) Robert

If I had that problem I would try a master reset and defrag the drives on the garmin and see if that improved it, especially if has been performing sluggishly recently. There have been some recent problems with parts of maps not rendering properly at the .nl site you mentioned - you can see the discussion on the garmin sub group on the openstreetmap forum site. But you are able to view all of the map on the device using basecamp so that can't be the problem I would think. Have you downloaded javawa for the device and see if it finds a problem with the maps? Maybe there are 2 maps with the same id that overlap or something? Is the drive on the device nearly full - if so, putting the maps on a larger sd card may help give it more breathing space.

permanent link

answered 16 Aug '14, 17:38

nevw's gravatar image

accept rate: 9%

edited 16 Aug '14, 17:50

Hmm, "defrag"? We are talking about flash drives, right? ;-) Flash drives should never get defragged. For flash storage it is only doing bad – no good.

Only having one map enabled (or even only one on the memory), gps device reset, maybe formatting the map storage sound most promising to me. Or simply trying out more maps – maybe old outdated ones (from not anymore updated garmin map directories) to have other mkgmap versions and other data versions involved (← I did not find such a provider in our Garmin download list).

(16 Aug '14, 18:21) aseerel4c26 ♦

Resetting the gps didn't help. I also used the map installer for BaseCamp form "" and then installed the map from BaseCamp to the gps. But I still have the same result.

When I enable only the default map (Europe) everything is ok. When both maps are enabled the European one is fine but not the Canada one. And of course when the Canada map is the only enabled there is the problem...

(16 Aug '14, 19:30) gamapr

I tried to download an old map from UK (October 2012 from "All in one Garmin Map") to see if there was the same problem. After the gps stopped (I think there was too much data to process in London) I went to a sparser area and it was working almost perfectly. The problem of missing area also appeared but it was less often. With a high zoom level I didn't find any problem.

(16 Aug '14, 20:56) gamapr

This is either a Garmin problem or a problem related to the maps from which is, by the way, a fantastic service.

You will find additional help by asking on the OSM Forum dedicated to those Free Garmin maps at The Forum deals with exactly this sort of problem.

(17 Aug '14, 02:23) AlaskaDave

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 16 Aug '14, 16:09

question was seen: 7,457 times

last updated: 29 May '20, 07:31

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum