I converted my Garmin tcx traces to gpx using GPSBabel. (all real cycling traces by me) Have tried uploading 10 files but all returned the error message "Found no good GPX points in the input data". The files appear to have lat long info and timestamps with every point. Sample below. Can anyone help please?

<?xml version="1.0" encoding="UTF-8"?>
<gpx version="1.0" creator="GPSBabel - http://www.gpsbabel.org" xmlns="http://www.topografix.com/GPX/1/0">
 <time>2014-08-09T21:07:34.767Z</time>
 <bounds minlat="47.320054000" minlon="8.580319000" maxlat="47.345269000" maxlon="8.599789000"/>
 <wpt lat="47.322196000" lon="8.585315000">
   <ele>469.949000</ele>
   <time>2013-11-10T09:01:21Z</time>
   <name>LAP001</name>
   <cmt>LAP001</cmt>
   <desc>LAP001</desc>
 </wpt>
 <trk>
   <name>2013-11-10T09:01:19Z</name>
   <trkseg>
    <trkpt lat="47.322196000" lon="8.585315000">
      <ele>469.949000</ele>
      <time>2013-11-10T09:01:21Z</time>
    </trkpt>
    <trkpt lat="47.322183000" lon="8.585332000">
      <ele>551.502000</ele>
      <time>2013-11-10T09:01:22Z</time>
    </trkpt>
    <trkpt lat="47.322077000" lon="8.585497000">
      <ele>552.915000</ele>
      <time>2013-11-10T09:01:31Z</time>
    </trkpt>
    <trkpt lat="47.321982000" lon="8.585646000">
      <ele>554.167000</ele>

asked 10 Aug '14, 22:14

tomorite's gravatar image

tomorite
11112
accept rate: 0%

edited 10 Aug '14, 22:40

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551

Thank you for testing this out. I looked at the file in First Object XML Editor and there looks to be only one track and track segment. Skipping to the end of the track my file looks like this. Any help appreciated. Thank you.

<Trackpoint><Time>2013-11-10T10:01:14Z</Time><Position><LatitudeDegrees>47.321353</LatitudeDegrees><LongitudeDegrees>8.580461</LongitudeDegrees></Position><AltitudeMeters>500.245</AltitudeMeters><DistanceMeters>11431.077</DistanceMeters><HeartRateBpm><Value>113</Value></HeartRateBpm><Cadence>0</Cadence></Trackpoint><Trackpoint><Time>2013-11-10T10:01:19Z</Time><Position><LatitudeDegrees>47.321335</LatitudeDegrees><LongitudeDegrees>8.580319</LongitudeDegrees></Position><AltitudeMeters>499.463</AltitudeMeters><DistanceMeters>11442.013</DistanceMeters><HeartRateBpm><Value>109</Value></HeartRateBpm><Cadence>0</Cadence></Trackpoint></Track></Lap><Creator xsi:type="Device_t"><Name>EDGE705</Name><UnitId>3420061569</UnitId><ProductID>625</ProductID><Version><VersionMajor>3</VersionMajor><VersionMinor>30</VersionMinor><BuildMajor>0</BuildMajor><BuildMinor>0</BuildMinor></Version></Creator></Activity></Activities><Author xsi:type="Application_t"><Name>EDGE705</Name><Build><Version><VersionMajor>3</VersionMajor><VersionMinor>30</VersionMinor><BuildMajor>0</BuildMajor><BuildMinor>0</BuildMinor></Version><Type>Release</Type></Build><LangID>EN</LangID><PartNumber>006-B0625-00</PartNumber></Author></TrainingCenterDatabase>
(11 Aug '14, 19:31) tomorite

I have tested a file based on your snippet (with the cut-off closing tags </trkpt> </trkseg> </trk> </gpx> added): valid XML ("The uploaded document "foo.gpx" was successfully checked as well-formed XML."). A good basis for a successful gpx file upload.

I have tried to upload, and it worked (link to trace). So there must be something wrong in a later part of your file. Maybe check that there is only one track segment and only one track in one gpx file (I am not sure if the osm.org server-side software can handle multiple ones).(← that works – see comments below)

By the way, as far as I know the server would not accept a gpx file which has no timestamps, but even one timestamp is enough (which your track has).

permanent link

answered 11 Aug '14, 00:40

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551
accept rate: 18%

edited 12 Aug '14, 22:02

(11 Aug '14, 07:56) andy mackey

This may be mainly of academic interest by now, but I can confirm that at least one of my uploaded GPX files (Hayling.gpx) contains multiple tracks, and that some of the tracks contain multiple track segments. I have also uploaded several GPX files containing both waypoints and tracks.

(11 Aug '14, 22:36) Madryn

@Madryn: okay, fine, thanks for the info (I just was not sure – and to be safe …). Do you also see all tracks and track segments via the OSM api then? Or only the first one? Yes, waypoints work fine – if there at least is one trackpoint with a timestamp.

(12 Aug '14, 00:11) aseerel4c26 ♦
2

I regularly upload files with multiple tracks, and all tracks are visible. Tracks with multiple track segments are not so common, but I have just uploaded one and I can see both segments.

(12 Aug '14, 19:42) Madryn

(I'm guessing a lot here since I'm not familiar with .tcx)

TCX seems to be "Training Center XML" - it's not GPX as such. Are both samples that you posted from after the conversion? Could you pastebin an original TCX file, the actual GPSBabel commands you used, and the resultant GPX file perhaps? It seems odd that your second XML seems to have "lap" etc. in there.

If you'd like to see what valid GPX traces look like, perhaps look at some of mine. In case you haven't seen it, this external link may be useful.

permanent link
This answer is marked "community wiki".

answered 11 Aug '14, 19:45

SomeoneElse's gravatar image

SomeoneElse ♦
32.3k63335756
accept rate: 15%

You're right, the second sample is from the tcx whereas the first is from the converted gpx. My mistake. The GPSBabel gpx ends in the sample below. There is only one track and one track segment. I downloaded one of yours & it looks v similar. Pastebin of TCX & GPX at "Sample TCX 2013 11 10" and "Sample GPX 2013 11 10" valid for one hour. Thank you

<trkpt lat="47.321353000" lon="8.580461000"> <ele>500.245000</ele> <time>2013-11-10T10:01:14Z</time> </trkpt> <trkpt lat="47.321335000" lon="8.580319000"> <ele>499.463000</ele> <time>2013-11-10T10:01:19Z</time> </trkpt> </trkseg> </trk> </gpx>

(11 Aug '14, 20:36) tomorite

Pastebin files valid for 1 week.

(11 Aug '14, 21:42) tomorite

What are the full pastebin URLs?

(11 Aug '14, 21:46) SomeoneElse ♦
1

I've just saved the .gpx locally, uploaded it (as a private trace) and that's worked without errors. Not sure what the problem was?

(11 Aug '14, 22:38) SomeoneElse ♦
1

Thanks for your help. Today it worked fine. As a regular user of OpenStreetMap I wanted to be able to at least contribute data. Your help meant that I didn't give up

(12 Aug '14, 20:17) tomorite
showing 5 of 6 show 1 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×236
×224
×97
×3

question asked: 10 Aug '14, 22:14

question was seen: 3,569 times

last updated: 12 Aug '14, 22:02

powered by OSQA