NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I am used to editing with Potlatch2 within Firefox. But for some days now it does not come with a background imagery anymore. The background listbox is empty. This problem does not exist in Internet Explorer. What can be the cause and what can I do about it?


asked 08 Aug '14, 23:51

padvinder's gravatar image

accept rate: 100%

edited 09 Aug '14, 00:36

aseerel4c26's gravatar image

aseerel4c26 ♦

At least I can confirm the behaviour in my Firefox with many addons (link to edited location). You could try out what happens without https (in case you also used it), what happens with a new Firefox profile without any addons or non-standard settings or on another computer.

(09 Aug '14, 00:35) aseerel4c26 ♦

Please check if an addon might block the tile provider (BING). I had some problems with EFF privacy badger. You might want to start FF in failsafe mode.
Another idea is to use the FF dev tools (or Firebug) to trace what happens with the request to the tileserver.

(09 Aug '14, 09:53) iii
(10 Aug '14, 00:59) aseerel4c26 ♦

I do not know what is the reason but the problem does not exist anymore. I have not changed anything. Somebody fixed the bug?

(16 Aug '14, 19:12) padvinder

I do not notice a difference in the http/https requests. Maybe something else changed. By the way: could you please add a link to this question into your issue on github?

(16 Aug '14, 19:45) aseerel4c26 ♦

And now, almost 10 months after the problem seemed to have solved itself, it is there again...

(28 May '15, 21:27) padvinder

Are you using "https everywhere"?

(28 May '15, 21:42) SomeoneElse ♦

Please note the github link above as cited by @aseerel4c26 is not the Potlatch 2 issue tracker - that resides on

(30 Jun '15, 13:19) Richard ♦
showing 5 of 8 show 3 more comments

Thanks! The comments above made me check the addons in FF. I found out it has to do with addon 'HTTPS Everywhere'... Until recently this problem did not exist. I am using 'HTTPS Everwhere' for quite some time already and for good reason I think. So this is annoying. Also to notice is that the problem is not there with an other editor, 'ID OSM Editor'. There I do get a background image (Bing). But I do not like this ID editor.

permanent link

answered 09 Aug '14, 17:15

padvinder's gravatar image

accept rate: 100%

Sad to hear that, I also use HTTPSeverywhere. Does the addon give a reason why it bans P2 tiles providers?

(09 Aug '14, 19:54) iii

HTTPS Everywhere supports enable/disable rules for specific web pages. While this seems to be a problem of potlatch2 you can at least circumvent it without having to disable HTTPS Everywhere completely.

(15 Aug '14, 22:11) scai ♦

It may be the new request to which supports https (so it may get switched-over to https by https everywhere) but is not accessed via https by potlatch2 (even if the osm page is loaded via https).

(15 Aug '14, 22:15) aseerel4c26 ♦

As a general rule I tend to assume that the sort of person who uses HTTPS Everywhere is a typical JOSM user and not the sort of person who uses Flash. But I'll see if there's some sort of workaround that can be added to P2.

(17 Aug '14, 11:53) Richard ♦

@Richard: Thanks, and agree regarding JOSM. ;-) I would be interested to know what technically causes the apparent incompatibility of HTTPS-E with P2. I mean, usually HTTPS-E just rewrites/replaces HTTP requests for HTTPS-enabled sites.

(17 Aug '14, 12:41) aseerel4c26 ♦

Oh, Flash access rules are a law unto themselves (e.g. crossdomain.xml, which was effectively CORS before CORS existed).

(17 Aug '14, 16:51) Richard ♦

I thougt I posted this before: problem seems solved.

(19 Aug '14, 09:17) padvinder
showing 5 of 7 show 2 more comments

Potlatch2 I believe switched to using the imagery index a couple of days ago. This may be an issue caused by the change. Please file a bug report here:

permanent link

answered 09 Aug '14, 12:38

SimonPoole's gravatar image

SimonPoole ♦
accept rate: 18%

I have tested it now (had no, nothing, imagery in firefox). For me the key problem was that, as Simon has written before, the imagery index was switched. It even was switched to a new domain ( ). My browser addon "Request Policy" was blocking this new cross-domain request (which is correct because this addon is whitelist-based and I had not allowed this domain before).

Also, if you are accessing the osm homepage via httpS, then (sadly) some http requests ("mixed content") must be allowed for several domains (check your browser and addon security logs in case you are blocking this - e.g. via ctrl+shift+k in Firefox).

(15 Aug '14, 20:18) aseerel4c26 ♦

Strange: yesterday I added an new message (that after 10 months the problem is there again). By email I receive a message that someone commented on that. But now here I can not find nor my message, nor the comment (whether I use 'https everywhere' - answer yes) of that someone else.

(29 May '15, 12:33) padvinder

@padvinder - what happened was that someone moved your answer to a comment below the question, and my comment on your answer is now below that.

Re "https everywhere" - that'll be the problem then.

(29 May '15, 12:36) SomeoneElse ♦

Please do not file any bug reports at, that isn't the Potlatch 2 issue tracker.

(30 Jun '15, 13:20) Richard ♦

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 08 Aug '14, 23:51

question was seen: 4,760 times

last updated: 30 Jun '15, 13:20

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum