NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum


some days ago I walked through a wooded area in Ireland, and noticed that the offline map downloaded to my Android device a week earlier didn't show the northern half of that forest; when that night I logged in to to add it, it was already there.

However, the next day, it still didn't appear in the map - or rather, at different zoom levels, you could see all/nothing/the southern half/the western half.

I waited another day - no change.

So I looked (in Potlatch 2) at the entries for that forest and compared it to others in the area that did show on the map.

The only difference I could see was that the others had a relation Multipolygon/outer, and this one didn't.

So, I added that relation 14 hours ago; as a result, the forest vanished completely from the map at most zoom levels.

I deleted the relation (created with Potlatch) and created a new one in iD 10 hours ago.

This morning, the forest is still not there.

Can someone who knows OSM editing well (which I obviously don't) check what's wrong here?

My "Aenderungssatz" (changeset) is #24231492, and the northern end of the forest should be around the coordinates 52°03'47.2" (N), -09°32'12.2" (W).

EDIT: I just cleared my browser's cache again and went through all zoom levels; the whole forest is visible at zoom level 14; I don't think it was before, so something may indeed be happening, just VERY slowly???

asked 19 Jul '14, 10:47

Marabu_Too's gravatar image

accept rate: 0%

edited 19 Jul '14, 11:19


There's a long and detailed explanation of how and when edits show up here.

(19 Jul '14, 11:17) SomeoneElse ♦

First thing: Check how often the vector maps you use are updated and that you use one created some time after creating/changing a feature in OSM. Even when the vector map is created one or two days after your edit that doesn't mean that this map contains your edit due to possible delays in the tool chain of the map creator.

Second thing: I removed the forest in the south from the MP since there was no need to have it as "outer" in the MP. (changeset)

Hint: The wood I removed from the MP overlaps lavishly with the landuse=residential North East of it. That's no good mapping style.

Else I didn't see anything which should make the forest disappear from maps.

permanent link

answered 19 Jul '14, 18:24

malenki's gravatar image

accept rate: 6%

edited 27 Jul '14, 19:49

Thanks - seems to have been a lack of coordination here.

If I understand you correctly, the "southern half" that I saw was actually a second bit of forest in the same place as the one that was missing?

(I didn't draw either, by the way; just noticed that something was wrong.)

I suppose that - for what ever reason - this forest just takes time (electronic trees which will have to grow?) ;-)

On my Android device the forest ist now visible in the online maps provided by Mapquest as well as by Hike&Bike, though not, strangely, in OSM (either on my PC or on my Android device).

We'll just have to wait and see, I suppose.

Kind regards,


(20 Jul '14, 19:26) Marabu_Too


I just checked again, and the forest which should just reach Victoria Lodge from the east in

is STILL not visible.

Surely 12 days is excessively long for such a small area, and it SHOULD by now be visible?

When I noticed that it did not appear on the map 12 days ago (not having drawn it myself), I added a multipolygen relation; this has now been removed again by someone else, but surely that shouldn't prevent it from being visible?



(31 Jul '14, 10:20) Marabu_Too

Just to notice that in MapQuest Open and Humanitarian layers the forest is well visible.

(31 Jul '14, 10:40) NonnEmilia

@Marabu_Too: strange, indeed. It is a closed way (checked with JOSM's validator). It is shown by MQOpen and Humanitarian layers but not the standard one. I tried with /dirty, but no success. Not sure what's wrong here. At least I can confirm your observations. ;-)

(31 Jul '14, 10:44) aseerel4c26 ♦

at nevw:

you're right - it's there in several zoom levels; probably just wanted a bit of attention! ;-)

(31 Jul '14, 11:13) Marabu_Too

....or is your "Added one node" responsible for this?

(31 Jul '14, 11:15) Marabu_Too

I don't know but the same thing happened to another mapper and I added a couple of nodes and saved and it did the trick then too. Sometimes things just get hung up for whatever reason I guess and just need an extra push. I don't know if I helped or it was just umpteen people dirtying the tiles that did the trick. ???

(31 Jul '14, 11:20) nevw

It's certainly worth keeping in mind for a similar case; thanks anyhow!

(31 Jul '14, 11:48) Marabu_Too
showing 5 of 9 show 4 more comments

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 19 Jul '14, 10:47

question was seen: 4,369 times

last updated: 31 Jul '14, 12:04

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum