NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum


I'm having a curious problem. I need the buildings of the city of Utrecht (The Netherlands). And for that, I downloaded the appropriate osm from

However, when I open the osm to further process in other software (c4d), it turns out that only about 50% of the buildings I see in my bouding box are in the downloaded osm file.

Can it be that I need for example to turn on additional layers or activate additional objects?

Many thanks in advance for any pointers in the right direction.

Best regards,


asked 02 Jul '14, 15:51

aesgewei's gravatar image

accept rate: 0%

edited 05 Jul '14, 16:29

malenki's gravatar image



Please tell us how you downloaded your data. And try to list specific objects missing in your software. For example by activating the data layer at and providing the exact URL for a missing object.

(02 Jul '14, 16:35) scai ♦

I wonder if it could be related to the 64 bit ID issue? Sounds a lot like what would happen in QGIS before it got fixed.

(02 Jul '14, 17:04) neuhausr

I downloaded the data (that I specified w/ the bounding box) thru Overpass API.

The data that is missing contains buildings.

I'm sorry to say, but I'm a total noob at openstreetmap, so I do not know how to a) find a specific data layer, b) activate it or c) provide an exact url.

(02 Jul '14, 19:44) aesgewei

See browse in the OSM wiki. First, go to the area in question and zoom very close to the missing object. Then open the layer menu (4), activate [x] Map Data and wait a little until the data has been loaded. Afterwards select a building which you think is missing, this will open a sidebar on the left where you can see additional information about the object. Your browser should now show the URL to the object you just opened.

Additionally it will help if you can show us your Overpass API query.

(02 Jul '14, 19:57) scai ♦

Thanks! The url of a missing building is:

My Overpass API query:,52.0464,5.1910,52.1560

The OSM data vs the imported data w/ missing objects:

(02 Jul '14, 20:26) aesgewei

This is a node which is part of three highways, not a a building. Try to select the outline of a missing building.

(02 Jul '14, 20:32) scai ♦

Can you open the .osm file with a text editor, and search within it for some of the "missing" node or way IDs? If they are present in the .osm data file, but not showing in c4d, then it may be an issue with how c4d processes the data.

(02 Jul '14, 20:46) neuhausr

By the way: thank you all for sharing your thoughts!

(03 Jul '14, 08:20) aesgewei
showing 5 of 8 show 3 more comments

Hello all,

I revised a work-around outside osm, creating missing splines in illustrator due to time restrictions. My current problem is therefor partly solved; however, I fear w/ future projects to run into the same problems.

Should I close this topic or leave it open for additional answers?

permanent link

answered 07 Jul '14, 08:57

aesgewei's gravatar image

accept rate: 0%


When I try to download the city of Utrecht with JOSM from the OSM API I am told I ask for too much data.

For downloading big amounts of data you should either query the Overpass API (you can do this with JOSM and the mirrored_download plugin and even filter for certain types of objects)
or get your country from geofabrik and pre-process it with osmium and osmfilter

permanent link

answered 05 Jul '14, 12:29

malenki's gravatar image

accept rate: 6%


While this is all very true, I fail to see how this is an answer to the question.

(05 Jul '14, 15:03) cartinus

The only question the author asks ("Can it be that I need for example to turn on additional layers or activate additional objects?") can be answered with a simple "no". Better INYO?

My answer should help the author to get a complete data set instead one with only 50%.
Furthermore it is discouraged to pull big data sets from the OSM API.

(05 Jul '14, 16:12) malenki

Have you looked at or used the export tab at the homepage recently? If the area is too big, it does not give you a borked result set. Furthermore directly below the export button is an overpass link that gets you the map data from the bounding box. All without having to install JOSM + plugins and having to learn overpass query syntax. If the OP got his data from the page, then he probably used overpass without realizing what it was.

If you read the rest of the text on this page. You'll also notice the problem was not the downloading.

(05 Jul '14, 19:49) cartinus

The objects are not dropped at random. The buildings that are missing are the recently imported ones. The ones that are still visible are the ones that were imported four years ago.

By exporting a smaller area he could determine whether the problem is the number of objects or the 64-bit node ID's. If it's the first, then a smaller area should have buildings. If it is the second, then a smaller area shouldn't have them.

Compare this map with the C4D image linked above.

permanent link

answered 02 Jul '14, 21:47

cartinus's gravatar image

accept rate: 27%


Another difference is that all the old buildings will have the tag building=yes, but most of the new buildings will have another value than yes like house, apartments, retail, etc.

(02 Jul '14, 22:16) cartinus

I myself already tried exporting smaller areas, but the buildings are still missing. So it's definitely not that.

@ Cartinus: a) In what way does your map differ from the map I created op, that started off this topic? b) Do you want me to export the osm data from your map, import that in c4d and then compare it with the c4d image linked above? If so, I do not know how to export the osm data from your map. c) Or do you just want me to visually compare both maps? Is so, then I can safely say that in your map, there are also (as was in my own Openstreetmap boundingbox) way more buildings than in my c4d image.

(03 Jul '14, 08:20) aesgewei

...and it seems to me that the ones that are missing are the ones highlighted in red on the @cartinus image. Do you agree?

(03 Jul '14, 09:29) nevw

I agree. it sure looks that way.

I just got informed that the objects that are exported correctly, are Misc. Manmade Structures

The ones that don't get exported are Unknown Line Type.

No clue on why someone wouldn't want to define those (clearly manmade structures) as being Unknown Line Type, but that seems to be the problem.

(03 Jul '14, 09:45) aesgewei

The map I linked is made with the same data as and the export you made. I just linked to it, to show that the newly imported buildings (the reddish brown buildings) are the missing ones.

I made two files with osm data. They show the same small area around the Domplein. Both have only buildings and nothing else. The first on has buildings with all tags on them. In the second one all buildings have the tag building yes and no other tags at all.

Try importing them. If one or both fail to show buildings, then whoever made the import tool for C4D needs to fix his import tool. If it is a legal copy of this one, then they better well fix it for that money.

(03 Jul '14, 15:54) cartinus

And the links to the files:

(03 Jul '14, 15:56) cartinus

@ Cartinus, I think I'm doing something wrong when trying to follow your instructions.

First, the osm data you provided, is very small (1,1Mb) - is that correct?

Second, when importing either one of the 2 files, I end up w/ 3 objects (albeit that they're open paths). Both osm files succeed in importing and import the same. The only difference is that w/ DompleinBuildingYes.osm, I get only 1 tag imported and w/ DompleinFullTags.osm, I get several tags imported.

If you find that there should be indeed 3 objects, then both imports sounds ok.

However, they are not closed paths, but open paths, which sounds like something still isn't correct

(04 Jul '14, 07:32) aesgewei

These files contain much more objects (571 buildings to be exact) which you can easily verify when opening the file with a simple text editor. Sounds like a serious bug of the software you are using. Can you tell us which exact objects you see? Ideally by listing the node or way IDs.

(04 Jul '14, 07:50) scai ♦
showing 5 of 8 show 3 more comments


Try exporting small regions of the maps, rather than exporting huge windows.


permanent link

answered 02 Jul '14, 20:21

hypnotic%20meteor's gravatar image

hypnotic meteor
accept rate: 0%


Exporting large regions should not lead to objects being dropped at random.

(02 Jul '14, 20:32) scai ♦

Happens to me, the solution I found was selecting smaller regions.

(02 Jul '14, 20:36) hypnotic meteor

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 02 Jul '14, 15:51

question was seen: 8,872 times

last updated: 07 Jul '14, 08:57

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum