Hi,

Is there a problem with the ID editor? I can't select a way by clicking on it. The way gets highlighted when I hover over it with the mouse, but clicking it doesn't select it and thus I can't change nodes. When I create a new way I can change the nodes but I do not see the menu for the way that allows me to delete it.

Kai

asked 25 Jun '14, 13:13

ktroester's gravatar image

ktroester
41115
accept rate: 0%

closed 25 Mar '18, 23:55

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551

1

What browser are you using on what OS? Knowing that might help someone to replicate the problem.

(25 Jun '14, 13:18) SomeoneElse ♦
2

Thanks for reminding me to check other browsers. It works with Firefox 27.0 but doesn't work with Chrome 35.0.1916.153. Chrome is up to date. But using Firefox is an acceptable workaround for now.

(25 Jun '14, 14:20) ktroester

The question has been closed for the following reason "Outdated. @others: please open a new question if you have similar problems." by aseerel4c26 25 Mar '18, 23:55


This appears to be a known stubborn bug which manifests when using Google Chrome. See the following issues on github:

https://github.com/openstreetmap/iD/issues/1676

https://github.com/openstreetmap/iD/issues/1847

The only workaround I can find is to use a different browser for now. iD is useable, albeit not as snappy, in Firefox on this machine.

permanent link

answered 02 Jul '14, 03:55

wncoutdoors's gravatar image

wncoutdoors
7113
accept rate: 0%

edited 02 Jul '14, 03:56

Note that both are closed, so it my be a good idea to report it again as it is not fixed.

(02 Jul '14, 07:42) Bulwersator
1

I just did that for #1676.

(02 Jul '14, 07:52) scai ♦
2

Yep, the canonical issue appears now to be: https://github.com/openstreetmap/iD/issues/2151

(03 Jul '14, 19:47) wncoutdoors

Thanks for asking about this, I have tripped over this in Mapathons where new users with Chrome get an inexplicable loss of the ability to select anything...

(28 Mar '18, 03:12) DeBigC

Does anyone have a better Chrome fix and/or workaround to below? without suggesting another browser.

Main fix: logoff of OpenStreetMap, close ALL chrome browser windows, launch chrome again, re-logon to OpenStreetMap. Although sometimes i need to do this more than once to fix.

Workaround: hold SHIFT and select one or more objects, hit M then move the selection to new location, hit ENTER to confirm new location.

permanent link

answered 25 Jul '16, 20:25

rwilliam's gravatar image

rwilliam
3112
accept rate: 0%

regarding the "Workaround": but then the objects are at a new location. The question was how to select, wasn't it? Or do you use undo afterwards and then the objects still are selected?

(25 Jul '16, 20:56) aseerel4c26 ♦

Is this still relevant? I can not reproduce this with Chrome 52 (current) - clicking selects correctly. Perhaps try with disabled addons?

(26 Jul '16, 14:36) Piskvor

Yeah sorry, i only mentioned moving objects because the previous post had a link in which someone said the [shift] workaround doesn't work for moving, to which i found it works with [enter]. I should have made that clearer.

With regard to if still relevant. I rarely get the issue, but occasionally if i leave my browser running for an hour or so without editing, then try more edits it happens again.

My Chrome is up to date, and i got the issue today. Updated 2 days ago to version 52.0.2743.116 m

(11 Aug '16, 14:38) rwilliam

I use the SHIFT workaround constantly, it works every time.

(11 Aug '16, 15:13) scass

Bug STILL there in chrome version 54.0.2840.99 (64bit with Win10). Best work around for me is the SHIFT one mentioned above.

(08 Dec '16, 10:53) AndyT8
2

Check with the 'latest code' version at https://openstreetmap.us/iD/master - it should be fixed now, just not necessarily deployed to osm.org yet.

(08 Dec '16, 11:43) Richard ♦
showing 5 of 6 show 1 more comments

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×262
×71
×12
×2

question asked: 25 Jun '14, 13:13

question was seen: 9,038 times

last updated: 28 Mar '18, 03:12

powered by OSQA