Thanks to previous posts, answers and links, I made a custom OSM map, loaded the gmapsupp.img (288 MB) into my new etrex 20 but it doesn’t show up in the map directory (just the two that come with it - worldwide DEM & digital globe). What now?

asked 15 Jun '14, 15:12

owennatekha's gravatar image

accept rate: 0%

edited 16 Jun '14, 00:17

aseerel4c26's gravatar image

aseerel4c26 ♦

Could you describe in a bit more detail the steps that you took? Without that, it will be tricky to work out what the problem is.

(15 Jun '14, 15:14) SomeoneElse ♦

It’s loaded onto a micro-sd card with Garmin directory added. I then put the card into the etrex.

(15 Jun '14, 15:49) owennatekha

Your steps sound correct. Maybe your file is broken? Try to get another OSM map for Garmin.

(15 Jun '14, 17:33) scai ♦

I’ll try that and report back. Thanks

(15 Jun '14, 20:45) owennatekha

I have an etrex 30 and found this guide was helpful.

(16 Jun '14, 03:36) nevw

I’m back and no luck. Downloaded a smaller gmapsupp.img (189 MB). Installed it in a garmin directory I created on the micro-sd card. The GPS still has just the two default maps.

NEVW - I love the detail on the dcrainmaker instructions. Thanks. I followed all those steps.

I think I’m stuck on the enabling stage. Is there some re-boot step I’m missing?

(17 Jun '14, 17:51) owennatekha

The device should automatically (re)boot after unconnecting it from your PC and pressing the power button. Have you checked that your SD card is formatted as FAT32 (this should be the default after purchasing it)?

(17 Jun '14, 19:15) scai ♦

I copied the .img file onto the card which was in my laptop (a MAC). I then put the card into the GPS. No luck.

Then I deleted the .img file in the Garmin directory on the card in the eTrex and loaded the .img file from the laptop directly onto the eTrex - which is holding the card with the garmin directory on it. (It took several minutes longer to do it this way.) When it was loaded (185 MB), I disconnected and rebooted. Still no luck.

The .img file on the card says it has to be opened with DiskImageMounter. Is that right?

I will check the card (brand-new Lexar) to see if it is FAT32 format. How do I do that?

(17 Jun '14, 20:28) owennatekha

In my iMac, to check format, click apple icon in top left corner, About This Mac,More Info...,System Report,Hardware...Storage, and you should see your sd card listed probably similar to this...


Available: 12.41 GB (12,406,489,088 bytes)
Capacity: 16.01 GB (16,012,804,096 bytes)
Mount Point: /Volumes/ETREX-USD
File System: MS-DOS FAT32
Writable: Yes
Ignore Ownership: Yes
BSD Name: disk3s1
Physical Drive:
Media Name: Garmin GARMIN Card Media
Protocol: USB
Internal: No
Partition Map Type: MBR (Master Boot Record)
S.M.A.R.T. Status: Not Supported

(17 Jun '14, 22:45) nevw

Also have a read of some of the "Related questions" at the right side of this page for hints to the solution.

(17 Jun '14, 22:52) nevw

This tool by JaVaWa may help find the problem too. "JaVaWa Device Manager helps you to manage the contents of your Garmin device and accompanying (micro) SD cards in an easy way."

(17 Jun '14, 22:55) nevw

Here’s what I found:


Available:  1.86 GB (1,863,188,480 bytes)
Capacity:   1.96 GB (1,956,589,568 bytes)
Mount Point:    /Volumes/GARMIN
File System:    MS-DOS FAT32
Writable:   Yes
Ignore Ownership:   Yes
BSD Name:   disk1
Physical Drive:
Media Name: Garmin GARMIN Flash Media
Protocol:   USB
Internal:   No
Partition Map Type: Unknown
S.M.A.R.T. Status:  Not Supported

Looks okay?

I have a Mac and used the Should I have used the generic_macosx.Zip instead?

(17 Jun '14, 23:01) owennatekha

If you don't find a solution in this group you could try asking at this active and helpful site

(17 Jun '14, 23:21) nevw

assuming from something like this...and the easiest way is download unzip the and copy to your sd card in to the /Garmin directory.

The server has generated four different configurations of your map:
_windows.exe = Installer for Garmin BaseCamp/MapSource (Windows). = Installer for Garmin BaseCamp/RoadTrip (Mac OSX) = Combined image for direct manual placement on the GPS device (gmapsupp.img) = ...etc is only useful if you have Garmin BaseCamp

(18 Jun '14, 00:03) nevw

Above you have listed the Garmin internal drive. You should also see a separate listing for the sd card storage and that is the one where the you want to put the new map. You need to have the Etrex connected and in mass storage mode I guess.
(though you can put it on the internal drive under the Garmin directory if you wish - just don't overwrite any files there. It is safer to put all your extra stuff on the sd card)

(18 Jun '14, 00:15) nevw

Re nevw's comment about 'safer to put all your extra stuff on the sd card'. I'd second that. Avoids any risk of 'bricking' your Etrex unit. Also, if your computer has a card reader, it is quicker to transfer your downloaded map by putting the sd card in the card reader rather than leaving it in your Etrex.

(18 Jun '14, 00:42) NZGraham

NEVW - here is the info on the 16 GB card in the eTrex:


Available: 15.15 GB (15,148,220,416 bytes) Capacity: 16 GB (16,004,415,488 bytes) Mount Point: /Volumes/NO NAME File System: MS-DOS FAT32 Writable: Yes Ignore Ownership: Yes BSD Name: disk2s1 Physical Drive: Media Name: Garmin GARMIN Card Media Protocol: USB Internal: No Partition Map Type: MBR (Master Boot Record) S.M.A.R.T. Status: Not Supported

(18 Jun '14, 01:18) owennatekha

looks the same as mine. I'm out of ideas :(

(18 Jun '14, 01:44) nevw

If you installed try downloading the very little .img below. Copy into the /Garmin directory on the sd card and see if you can view in JaVaWa via 'manage maps' on the sd drive, 'Map Coverage'. You should see a bit of Mount Coot-tha. This is a little Garnin Leisure version of osm and was downloaded from and can be seen on my Etrex. It should show using JaVaWa (not ready seen on your Etrex unless you zoom to that area) but will test a map that works fine here on my Etrex.

(18 Jun '14, 02:22) nevw

Ooops...Correction to BBBike as referenced above. It goes to a slightly different page than I expected though still by the same group. Here is the link where you can download a quite small area to test such as around your suburb (just a few MB) There are quite a few formats available but you need anyone of the Garmin varieties.

There still may have been a problem with the 189MB .img you have already downloaded so it might be time to try a different one.

(18 Jun '14, 12:31) nevw
showing 5 of 20 show 15 more comments

The problem is solved. Finally. The problem was the SD card (16GB). I replaced it with a different brand and smaller size (8GB) and everything worked fine.

Many thanks to all who thought about my problem and offered suggestions.

permanent link

answered 20 Jun '14, 19:28

owennatekha's gravatar image

accept rate: 0%


@Andy This FAQ entry is not about the eTrex 20/30 devices. Unfortunately Garmin failed to provide a FAQ entry for these devices and didn't mention the max size in the specifications either. But according to various forum entries 8GB is the largest microSD card size supported by the eTrex 20/30 devices.

(21 Jun '14, 21:06) scai ♦

Your correct, I didn't have time to find more specific info. but it does illustrate how varied Garmins are. Just checked to see what as worked in my Oregon 450, it is an unbranded HC 16GB.

(22 Jun '14, 08:46) andy mackey

I bought an eTrex 30 from Johnny Appleseed in Dec2013 and it is quite happy with a 16GB micro sd card. I was told by the staff I could fit a 32GB card but there were compatibility problems with them and they suggested that 8 or 16GB should be amble and I think that is fair comment. I wonder if a reformat of owennatekha's card would have fixed it.

(22 Jun '14, 11:05) nevw
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 15 Jun '14, 15:12

question was seen: 3,053 times

last updated: 22 Jun '14, 11:06

powered by OSQA