Hi, I am trying to run an overpass instance on my own server but I'm stuck.

I can successfully run static queries on the server and they work as expected. Now i'm trying to get the Web service API working but Im having trouble.

If I run the command

http://195.53.128.67/api/interpreter?data=way(50.838400,%20-0.124373,50.839240,%20-0.122571);

I get the message

Error: runtime error: open64: 2 No such file or directory /osm3s_v0.7.4_osm_base Dispatcher_Client::1

Now, if I try to start the dispatcher server:

sudo nohup /root/osm-3s_v0.7.4/build/bin/dispatcher --osm-base --db-dir=/root/osm-3s_v0.7.4/db --meta &
tail -f nohup.out

It tells me:

File_Error Address already in use 98 /root/osm-3s_v0.7.4/db//osm3s_v0.7.4_osm_base Dispatcher_Server::4

Does anyone know anything I can try to get it working please? Ive been battling with this all weekend This is driving me crazy!

Thanks in advance :)

asked 26 May '14, 18:47

gmeister4's gravatar image

gmeister4
608812
accept rate: 0%

1

Address already in use seems to indicate that there's another process which is already bound to the same TCP/IP socket. What does netstat -t tell you?

The wiki page I originally quoted here was talking about some issues with stale lock files in /dev/shm. But your error message seems to point to another issue.

(26 May '14, 19:15) mmd

Hi mmd thanks for getting back to me,

I did know about the lock and had deleted it.

Here is the output of netstat -t

tcp 0 64 StreetServer:ssh cpc1-brig15-2-0-c:61674 ESTABLISHED tcp 0 0 StreetServer:ssh cpc1-brig15-2-0-c:61626 ESTABLISHED tcp 0 0 StreetServer:ssh pa1-160.wireless.:44703 ESTABLISHED tcp 0 0 StreetServer:ssh pa1-160.wireless.:39404 ESTABLISHED tcp 0 0 StreetServer:http cpc1-brig15-2-0-c:61676 TIME_WAIT

I am new to ubuntu :/

(26 May '14, 19:44) gmeister4

Sorry, I put in the wrong parameter for netstat (didn't have a system available). I was looking for active processes listening on tcp/ip ports. The following command should print those along with the respective program name.

sudo netstat -ltp

Sample output:

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 localhost:ipp : LISTEN 993/cupsd
tcp 0 0 :postgresql :* LISTEN 1280/postgres
[...]

(26 May '14, 22:03) mmd

Here it is:

root@GeoNet:~# sudo netstat -ltp

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 :smtp : LISTEN 597/master tcp 0 0 :http : LISTEN 15767/apache2 tcp 0 0 :ssh : LISTEN 1661/sshd tcp6 0 0 [::]:smtp [::]: LISTEN 597/master tcp6 0 0 [::]:ssh [::]:* LISTEN 1661/sshd

(27 May '14, 13:47) gmeister4

Now im getting a new problem, if I try to make a request I get a 403 forbidden error.

"You don't have permission to access /api/interpreter on this server."

I have run all the permission commands suggested here though: http://overpass-api.de/full_installation.html

Any ideas? Thanks

(27 May '14, 13:49) gmeister4

FYI: Someone else reported the same issue on stackoverflow just yesterday. It seemed to be caused by some stale lock files. Added this to the Overpass API troubleshooting section on the OSM wiki now.

permanent link

answered 03 Jul '14, 21:08

mmd's gravatar image

mmd
5.6k4988
accept rate: 37%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×340
×229
×225
×19
×1

question asked: 26 May '14, 18:47

question was seen: 4,451 times

last updated: 03 Jul '14, 21:08

powered by OSQA