hello dear osm-experts

fairly new to osm - i tried to run the following code

./osmconvert baden-wuerttemberg-latest.osm.pbf --all-to-nodes -o=baden-wuerttembergrestaurants.o5m
./osmfilter baden-wuerttembergrestaurants.o5m --keep="amenity=restaurant" -o=baden-wuerttembergrestaurants_2.o5m
./osmconvert baden-wuerttembergrestaurants_2.o5m --csv="@id @lon @lat restaurant:name addr:street addr:housenumber addr:city website email" 
--csv-headline -o=badenwuerttembergrestaurant_2.csv

the terminal gave back the following results - see the complain not enough space

martin@linux-70ce:~> cd osmosis/
martin@linux-70ce:~/osmosis> ./osmconvert baden-wuerttemberg-latest.osm.pbf --all-to-nodes -o=baden-wuerttembergrestaurants.o5m
osmconvert Error: not enough space. Increase --max-objects=
martin@linux-70ce:~/osmosis> ./osmfilter baden-wuerttembergrestaurants.o5m --keep="amenity=restaurant" -o=baden-wuerttembergrestaurants_2.o5m
osmfilter Warning: unexpected end of input file: baden-wuerttembergrestaurants.o5m
martin@linux-70ce:~/osmosis> ./osmconvert baden-wuerttembergrestaurants_2.o5m --csv="@id @lon @lat restaurant:name addr:street addr:housenumber addr:city website email" --csv-headline -o=badenwuerttembergrestaurant_2.csv
martin@linux-70ce:~/osmosis> cd..
martin@linux-70ce:~> mv *.osm.pbf ~/osmosis

well what can i do - how to limit the request to get results....

update:

well i think i have to try out Parameter --max-objects=50000000 but i am not sure how!?

asked 23 May '14, 03:56

say_hello_to_the_world's gravatar image

say_hello_to...
19232427
accept rate: 0%

edited 23 May '14, 14:01


Did you try increasing max-objects as suggested by the documentation?

permanent link

answered 23 May '14, 09:19

SomeoneElse's gravatar image

SomeoneElse ♦
32.1k63332751
accept rate: 15%

many many thanks update:

well i think i have to try out Parameter --max-objects=50000000 but i am not sure how!?

(23 May '14, 14:01) say_hello_to...
1

Just append it to your osmconvert call. You already pass various other parameters.

(26 May '14, 09:26) scai ♦

Hello!

You of course can use --max-objects parameter to increase the number of allowed objects – as suggested previously. Additional help is available via osmconvert's help function: --help

In my opinion, the better way in this case would be to first filter and then convert to .csv. This should work faster and there would be no need for applying any --max-objects parameter:

  • Convert baden-wuerttemberg-latest.osm.pbf to .o5m (osmconvert)
  • Filter restaurants (osmfilter)
  • Convert to .csv (osmconvert)
permanent link

answered 27 May '14, 19:49

Marqqs's gravatar image

Marqqs
448510
accept rate: 22%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×537
×37
×26

question asked: 23 May '14, 03:56

question was seen: 22,617 times

last updated: 27 May '14, 19:49

powered by OSQA