Hi, i'm new at OSM and I tried to install Tirex on debian. I already installed it on Centos successfully but on debian it won't work. Every time I try to start the tirex-master I get this message:

    missing path at /usr/bin/tirex-master line 518

I have no clue what this means because the line reads the config directory. When I provide the config dir via -c it doesn't work, too.

Sorry if the question has been posted already. Thanks for help.

asked 15 Mar '14, 22:38

adopin's gravatar image

adopin
11223
accept rate: 0%

edited 17 Mar '14, 00:55

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548


I suggest that you run (as user tirex) the command "strace -f tirex-master -d 2>&1 | less" which will list the system calls that tirex makes; towards the end of the list, just before the program terminates, you will see which files it tried to open and failed. Then check whether you have your config files right.

permanent link

answered 16 Mar '14, 10:27

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
69.0k806261079
accept rate: 24%

Thank you for the command. With this command I found the problem: I copied a wrong file into the renderer directory so tirex wanted to load the content of the directory which was not set in the file.

(16 Mar '14, 22:38) adopin
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×225
×14
×3

question asked: 15 Mar '14, 22:38

question was seen: 1,307 times

last updated: 17 Mar '14, 00:55

powered by OSQA