When I open rules in Maperitive. I keep getting an Error. Here's the link to my Maperitive rules: Maperitive Rules

This is the output I get

   > use-ruleset location="C:\Program Files\Maperitive\Rules\Better mapnik.mrules"
      Rendering rules could not be parsed:
      ERROR: Unexpected character ';' (0x3b) (line=904, col=7)
      ERROR: Unknown command '10,-10' (line=904, col=1)
   SCRIPT FAILED
   Script execution error (line 1): Rendering rules could not be parsed

How do I fix this? I want to use this because the default rule set is missing objects.

asked 21 Feb '14, 11:49

deco2208's gravatar image

deco2208
26111214
accept rate: 0%

Please show us your rules file at the corresponding lines (around 904).

(21 Feb '14, 13:10) scai ♦

There is an error on line 904 (exactly what the output says): you have some numbers wrapped to a line, which Maperitive cannot parse, obviously.

permanent link

answered 24 Feb '14, 14:26

Zverik's gravatar image

Zverik
58331015
accept rate: 10%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×531
×41
×20

question asked: 21 Feb '14, 11:49

question was seen: 3,514 times

last updated: 24 Feb '14, 14:26

powered by OSQA