On openstreetmap.org, mouse-wheel zooming is far too sensitive and impossible to control with an Apple Magic Mouse (whose “mouse wheel” is a touch panel). Using the website is very frustrating.

Specifically, while panning around with mouse click, every mouse-up risks zooming the map randomly in or out. Whether trying to zoom or not, even very small movements risk unintentionally zooming two or three levels at a time. Sometimes a zoom out is immediately followed by an unintentional zoom in, or vice versa. Sometimes I have to attempt a zoom several times in a row, and the repeated and jumpy visual zoom is on the verge of inducing motion sickness.

Is there a way to reduce the mouse-wheel sensitivity for the site? Barring that, is there a way to disable it?

Background info:

  • This is the mouse that comes with all desktop Macs.
  • There is no software sensitivity control for this mouse’s zoom.
  • Scrolling and zooming work very well in most other apps and websites (for example, scroll-zooming in Google Maps is pretty good).

asked 22 Jan '14, 20:05

Michael%20Zajac's gravatar image

Michael Zajac
26112
accept rate: 0%

edited 23 Oct '14, 21:08

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16236548


Not all desktop Macs - my Mac mini doesn't have one (I greatly prefer the Mighty Mouse).

This sounds like something that you could raise as an issue against the OSM website, though it'll probably require a developer with a Magic Mouse to fix it.

permanent link

answered 22 Jan '14, 20:23

Richard's gravatar image

Richard ♦
27.3k40243362
accept rate: 19%

(22 Jan '14, 22:55) Michael Zajac
4

Well, that quickly got shut down as a Leaflet problem, so I have posted to the Google group.

https://groups.google.com/forum/#!topic/leaflet-js/eIE4h7mOk1c

(23 Jan '14, 01:48) Michael Zajac
1

No response there, so I went to github, found these related bugs, and added a comment to the latter:

Zoom issues with Apple trackpad (Magic Mouse) https://github.com/Leaflet/Leaflet/issues/2154

Mouse wheel zooms too fast in FF https://github.com/Leaflet/Leaflet/issues/1794

(30 Jan '14, 19:59) Michael Zajac

Hallo Michael

I have this problem with the Apple Magic Mouse on a number of sites. You can disable the feature on your Mac under Preferences-Mouse but then, if like me, you use the feature elsewhere, you have to re-enable it - a bit of a fag really. So, to get around it, I simply bought and installed another (wired) mouse which has a zoom feature via the scroll wheel. This is less likely to zoom by accident. so now I use the Apple mouse for almost everything and simply change over to the wired mouse for zoomable maps.

Hope that helps

John

permanent link

answered 19 Apr '14, 11:38

Sunnyjohn's gravatar image

Sunnyjohn
3111
accept rate: 0%

The scrollmaps chrome plugin offers a partial fix. You have to hold the cmd button while scrolling in order to zoom.
https://chrome.google.com/webstore/detail/scrollmaps

permanent link

answered 29 May '14, 22:44

scottgallant's gravatar image

scottgallant
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×87
×85
×14
×3
×2

question asked: 22 Jan '14, 20:05

question was seen: 20,660 times

last updated: 12 Dec '14, 03:37

powered by OSQA