These straight brown arrows appeared in this track recording. Anyone knows what it means ?screenshot

asked 29 Dec '13, 12:16

Luis%20Bahiana's gravatar image

Luis Bahiana
30222
accept rate: 0%

edited 29 Dec '13, 14:53

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548


You most probably should change the maximum distance for which JOSM connects GPS points.
Just press F12 and you are on the right page to do so. (I've set mine to 120 m but YMMV).
Maybe you have to enable Expert Mode first (on the left bottom)

permanent link

answered 30 Dec '13, 01:57

malenki's gravatar image

malenki
4.7k24683
accept rate: 6%

edited 30 Dec '13, 02:01

You downloaded two parts of a track - the brown lines are the connection between both ends. That happend because your selected download area (I am assuming that you did not download data and gpx independently with different area settings) is smaller than the recording. I guess they are brown because you have switched on a speed-based colour-code for the gpx tracks (I think that is the default). You can change the styling (there speed-based colour-code seems to be selected) by rightclicking the gpx entry in the layer selector box.

You will notice that the brown arrows are at the edge of your downloaded area (as Hendrik says). If you delete the current gpx layer and download a larger area (at least for the gpx tracks) these brown arrows will disappear.

permanent link

answered 29 Dec '13, 14:51

aseerel4c26's gravatar image

aseerel4c26 ♦
31.9k16237548
accept rate: 17%

edited 30 Dec '13, 19:55

Just a small correction: these "shortcut" lines will not disappear when you download a larger area.

(30 Dec '13, 10:52) pbb

JOSM connects any ends of GPS data if you don't tell it not to.

(30 Dec '13, 12:22) malenki

@pbb: I meant it differently than you apparently understood. I have made that more clear now.

(30 Dec '13, 19:56) aseerel4c26 ♦

@malenki: but that "connects" is apparently the standard setting...

(30 Dec '13, 19:57) aseerel4c26 ♦

@aseerel4c26: Maybe one should file a bug/feature request to alter this behaviour.
(edit): The default is 200 m

(30 Dec '13, 20:21) malenki

@malenki: hmm, for me that behaviour is okay. That way you know which traces are belonging together. Well, maybe these fake connections should be only drawn dotted or something so they get not that easy confused with a real trace. But I would also be okay with another default setting, yes.

(30 Dec '13, 21:06) aseerel4c26 ♦
showing 5 of 6 show 1 more comments

Hi they might disappear by selecting a larger area. It looks like JOSM is making suggestions for a connection between the elements /ways.

permanent link

answered 29 Dec '13, 12:43

Hendrikklaas's gravatar image

Hendrikklaas
8.5k177210350
accept rate: 6%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×509
×310
×223
×2

question asked: 29 Dec '13, 12:16

question was seen: 3,987 times

last updated: 30 Dec '13, 21:06

powered by OSQA