Why is encryption via HTTPS not used throughout openstreetmap.org? It seems that only login functionality is handled this way.

I guess in the light of recent privacy issues complete encryption would be a good idea (ideally with an A rating).

asked 28 Dec '13, 01:30

Michael%20Lusher's gravatar image

Michael Lusher
21111
accept rate: 0%

closed 28 Dec '13, 09:28

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
69.9k806321096

I remember a comment by our sysadmin TomH on the progress of full HTTPS in trac but I cannot find it now. IIRC it was: we are working on it.

It may be better suited to discuss the "why" and what can be done and what can I do elsewhere but here on this site.

(28 Dec '13, 02:14) aseerel4c26 ♦

Wiki and ML are https, too. There forum is on the way: http://forum.openstreetmap.org/viewtopic.php?id=21546

(28 Dec '13, 08:12) iii

The question has been closed for the following reason "Not a question, really" by Frederik Ramm 28 Dec '13, 09:28


This is not a question that is suitable for this medium. If you want to discuss the issue, head over to the dev mailing list, and if you want to make a change request, do it on trac or github.

permanent link

answered 28 Dec '13, 09:27

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
69.9k806321096
accept rate: 24%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×87
×87
×17
×17
×4

question asked: 28 Dec '13, 01:30

question was seen: 3,545 times

last updated: 28 Dec '13, 09:28

powered by OSQA