NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Good day,

I'm new to the whole OSM thing and I'm trying to learn as I go along.

I'm currently working on a project where we are investigating to use OSM data as a possible input for travel time analysis. The problem we have found in our pilot study area is that a major arterial road is missing from the downloaded data. I've tried various sources and even downloaded the whole of Africa's data from the Geofabrik's website hoping to circumvent this problem.

Attached are two sceeenshots showing the problem: When I look on the OSM website Zambesi Drive is visible but when I open the data in QGIS it is not there only certain parts of it (the yellow circle shows the missing road section). The area is in Pretoria, South Africa.

  1. Is this normal behaviour?
  2. How can it be rectified if at all?

Thank you for your assistance with this.

Kind regards, Pierre

Note: screenshots are lost - due to a fault during software update

Note: screenshots are lost - due to a fault during software update

asked 07 Oct '13, 12:36

kramer's gravatar image

accept rate: 0%

edited 11 Apr '15, 14:41

aseerel4c26's gravatar image

aseerel4c26 ♦

Such inconsistencies are usually due to one of the sources not being quite up to date. Some ways to get garanteed up-to-date data include the export function of the main website, data downloaded from an editor, and the "map data" checkbox in the layers sidebar.

But in this case, it seems that wambesi drive has been last touched on the 19th of august, which make it sound unlikely that any source you used was that old. The geofabrik extracts for Africa and South-Africa-And-Lesotho are less than 24 hours old, in particular. Either you downloaded old data, or there is a bug in qgis, or there is a bug in the geofabrik extract.

Do you still have the problem when downloading the area using the export page ?

permanent link

answered 07 Oct '13, 13:17

Vincent%20de%20Phily's gravatar image

Vincent de P... ♦
accept rate: 19%

edited 07 Oct '13, 13:18

Hi Vincent, yes I've tried the export area on the OSM site first and because it didn't work I've tried the geofabrik download which had a update date of 19 Sept. 2013.

(07 Oct '13, 14:01) kramer

I've just exported the area and it looks OK in JOSM, and looks OK added as a vector layer in QGIS 1.8. They are missing if I use web, Openstreetmap, Load OSM from a file and tick the name and highway options. So looks like the problem is with QGIS rather than the data.

(07 Oct '13, 14:49) EdLoach ♦

Thanks for looking at this, I will investigate it further and provide feedback.

(07 Oct '13, 15:00) kramer

I've just installed JOSM and had a look and as EdLoach reported it showed up fine. Thanks all who spend time to provide answers.

(07 Oct '13, 15:44) kramer

Bug in the QGIS OSM plugin having to do with the 64 bit IDs--see

permanent link

answered 07 Oct '13, 16:01

neuhausr's gravatar image

accept rate: 21%


Note this is fixed with QGIS version 2.0. It is integrated support for OSM data, you don't need the plugin.

(07 Oct '13, 18:34) Vclaw

great to hear! I haven't had a chance to download 2.0 yet

(07 Oct '13, 18:41) neuhausr

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 07 Oct '13, 12:36

question was seen: 5,858 times

last updated: 11 Apr '15, 14:41

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum