I just used the iD-editor for the first time and was quite confused by all the buttons. I tried hovering my mouse over them but did not get any tooltips. Eventually I just tried clicking on the left pointing U-turn-arrow only to have all my information deleted. I still don't know if it is a reset or undo button.

I could not find any way to give feedback, a bug tracker or way to contact a developer so I am left to ask this as a question here.

asked 07 Aug '13, 16:03

John6's gravatar image

John6
16112
accept rate: 0%

edited 07 Aug '13, 16:27

SimonPoole's gravatar image

SimonPoole ♦
35.6k13266568


I see tooltips on every last button in iD when I hover over them. The one on the "Undo" button which you clicked isn't entirely clear and should probably have the word "Undo" added to it somewhere. Other than that they seem to be pretty decent.

Also, did you do the "Walkthrough" when it first fired up? This feature explains how to use the basic controls very well. You can start it at any time from the help menu.

The iD issue tracker is on GitHub: https://github.com/systemed/iD/issues

permanent link

answered 07 Aug '13, 16:34

ToeBee's gravatar image

ToeBee
976920
accept rate: 27%

2

And now I have created a ticket about the undo/redo tooltips not being clear: https://github.com/systemed/iD/issues/1670

(07 Aug '13, 16:55) ToeBee
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×245
×44
×13

question asked: 07 Aug '13, 16:03

question was seen: 1,399 times

last updated: 07 Aug '13, 16:55

powered by OSQA