2
1

I am testing openstreetmaps and I live in a suburb of Dayton, OH. The suburb is a "city" called Oakwood, however the mailing address is and always has been Dayton NOT Oakwood. As a result searches for any address in oakwood return no results.

I edited my own address at: 300 Volusia Avenue, Dayton OH 45409, however it is impossible to find it if you include Dayton in the address, you still need to use Oakwood. Once found and if you edit the address record it shows Dayton, NOT oakwood, but is still not searchable.

I also searched for a business, you can go here to see: http://www.dorothylane.com/Stores/locations.pl

The first location is located in Oakwood, but as you can see the address is Dayton NOT Oakwood.

I think what is needed here is to completely expunge Oakwood and replace it with Dayton since no one ever uses an address with Oakwood.

Of note, there are 2 other entities in Ohio called "Oakwood", so if any mass-replacement can be made it should only be for addresses in the 45409 and 45419 zipcodes.

Finally, I am assuming there is really no way I can fix this myself, aside from fixing every address in Oakwood, which would be impractical considering there are thousands of home. The only resolution I see is to replace Oakwood with Dayton.

Thanks!

Don Langhorne

asked 09 Jul '13, 15:28

dlangh's gravatar image

dlangh
41114
accept rate: 0%

I wanted to add, I have tried some other addresses, specifically the other locations for Dorothy Lane (I put the url to the locations in my original post).

The location in Springboro works, however the other location at 6177 Far Hills Ave, Dayton OH does NOT work. This address is not in Oakwood, but Centerville, though the mailing address for that is also Dayton. I managed to find this address in Openstreetmaps. It reports that it is at: 6177 Far Hills Ave, Wittes Corners, Oh. I have never even heard of Wittes Corners and I am quite certain no one else has either.

(09 Jul '13, 15:36) dlangh

I have a similar problem -- my home on Parland shows up as being in Terrell Hills when we are actually within San Antonio city limits.

(16 Dec '13, 15:22) jfelter
(16 Dec '13, 19:20) blahedo

This seems to be a genuine issue with Nominatim, which appears to ignore addr:city tags when searching for addresses. As Cartinus says, the admin boundary for Oakwood means that places within the boundary are assigned unambiguously to Oakwood.

I have wondered for some time how we might cope with postal addresses which contain elements which are do not reflect administrative boundaries. A large swathe of what is administratively London has addresses which are in Middlesex (a place which ceased to exist administratively in 1965). The Middlesex address element cannot be inferred and is not insignificant: particularly to separate Hayes, Middlesex from Hayes, Kent both of which are in Greater London.

Your address is, unfortunately for you, a particularly good example of this phenomenon. I am sure it must occur fairly frequently around the world. My feeling is that this may be fairly complex to solve in nominatim as it requires at least two search spaces (one for places in Oakwood administratively, and ones for Dayton postally).

permanent link

answered 16 Jul '13, 18:56

SK53's gravatar image

SK53 ♦
22.9k46233360
accept rate: 20%

This question is a bit too technical for this help site. What you need is some support from the geocoding tool 'nominatim' used by the main OSM site. The best I would suggest is that you ask again your question on the dedicated mailing list for geocoding : http://lists.openstreetmap.org/listinfo/geocoding (subscription is required to post a question but you can easily unsubscribe once your problem is solved)

permanent link

answered 12 Jul '13, 16:28

Pieren's gravatar image

Pieren
9.7k2075157
accept rate: 15%

1

Pieren,

thank you for your response. I will do as you suggest.

Thanks!

Don

(13 Jul '13, 18:08) dlangh
-4

You could download (JOSM, etc) the whole area (in one part or many) and do a search-and-replace on the troublesome tags. Once mastered, the search functions of JOSM, for example, are powerful.

Please do it VERY CAREFULLY.
- Make sure there are no objects that are outside the correct area and are changed.
- Make sure there aren't "side-effects" (tags that shouldn't be changed but are)
- Make sure you know what you are doing! One wrong command plus upload may mean a little disaster. Seek help from other mappers if needed!
- Please do not mix these changes with other types of changes when uploading.

permanent link

answered 15 Jul '13, 13:12

MCPicoli's gravatar image

MCPicoli
2.1k123046
accept rate: 24%

2

There are no "troublesome tags".

There are two administrative boundaries. Those are correct.

The problem is that the postal service considers one of them to be a part of the other. Nominatim simply can't handle this ambiguity.

(16 Jul '13, 01:42) cartinus
2

This is really not sensible advice for a first-time OSM user and is much more likely to cause problems that will need reverting.

(16 Jul '13, 06:41) Richard ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×84
×32
×8

question asked: 09 Jul '13, 15:28

question was seen: 6,560 times

last updated: 16 Dec '13, 19:20

powered by OSQA