NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I used to be able to use OAuth from JOSM. But a few months ago, authorisation was not possible anymore. Basic authentication still works fine. I was expecting this to be a temporary problem, but I still can't use OAuth. The error message I am getting is:

OAuth authorisation failed

The automatic process for retreiving an OAuth Access Token from the OSM server failed. Please try again or choose another kind of authorisation process, i.e. semi-automatic or manual authorisation.

I don't know how semi-automatic and manual authorisation work, but I would prefer to use OAuth over basic authorisation since that sends passwords unencrypted.

asked 19 Jun '13, 10:00

pbb's gravatar image

accept rate: 0%

You need to login to, click on your username, "my settings", "oauth settings" and check if JOSM is listed under "My Authorised Applications". If it isn't, you should try semi-automatic (don't worry, JOSM will guide you where you need to copy/paste what).

permanent link

answered 23 Jul '13, 18:57

Matija%20Nalis's gravatar image

Matija Nalis
accept rate: 11%

Seems like the automated process doesn't even work if JOSM is listed there (for generating a new token). But semi-automatic works.

(23 Jul '13, 19:20) scai ♦

JOSM is listed there seven times. The latest date is 4 months ago. Is this normal?

(24 Jul '13, 23:46) pbb

@pbb: only one entry is needed, except if you use different JOSM installations for which you created different Oauth authorisations. Each of those authorisations is like a different but working key to your account. I guess you only use the newest authorisations, so you can delete the previous ones.

(25 Jul '13, 01:30) aseerel4c26 ♦

Thanks, using semi-automatic authorization did the job! FWIW, I am using JOSM on serveral different machines, so that might explain the various authorizations.

(25 Jul '13, 22:39) pbb

In my case I had problems with the authentication using the Vespucci app in my Android phone and it was resolved by uninstalling and installing the app.

So there may be more than one solution to the problem.

permanent link

answered 27 Dec '19, 22:19

Z00l00k's gravatar image

accept rate: 0%

[Fixed] In case someone face the same error:

I've faced the same error, OAuth failed, either Fully automated, Semi Automated or Fully Manual, All failed. I was able to do everything in browser but couldn't comment or upload changeset. But I was able to do everything from mobile. So, I was confirmed that, problem was in my pc. And then today Imagery wasn't loading in JOSM. So I searched in browser for the solution and it says my clock is behind with red warning page. And immediately I assumed this is the reason for all those OAuth error. So I fixed the time (which was 1 year behind), and that fixed everything.

permanent link

answered 02 Aug '19, 12:07

zabir's gravatar image

accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 19 Jun '13, 10:00

question was seen: 5,269 times

last updated: 27 Dec '19, 22:19

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum