NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

I have been receiving the following error when I select Edit in Potlatch 2:

"The OpenStreetMap server encountered an unexpected condition that prevented it from fulfilling the request (HTTP 500) Feel free to contact the OpenStreetMap community if your problem persists. Make a note of the exact URL / post data of your request. This may be a problem in our Ruby On Rails code. 500 occurs with exceptions thrown outside of an action (like in Dispatcher setups or broken Ruby code"

I'm running Windows 7 64 bit using Firefox 20.0.1

asked 11 May '13, 11:29

alantw's gravatar image

accept rate: 0%

edited 15 Dec '18, 12:26

aseerel4c26's gravatar image

aseerel4c26 ♦

I have the same problem....please if you find the solution...tell me

(12 May '13, 08:05) kami_90

Can you further describe what you edited and/or where you edited (permalink)? Does it occur every time? Or just once? What do you need to do to let it appear? Editing with Potlatch2 works for me (Linux, Firefox 17.0.5).

(12 May '13, 14:30) aseerel4c26 ♦

I can't actually edit any map data as the error message occurs as soon as I select "Edit" from the menu, irrespective of the location of the map tile I am on

(12 May '13, 17:39) alantw

@alantw: Okay, thanks. So I assume Potlatch does not even load and no green P2 loading screen appears?

At this pos. clicking edit and editing with Potlatch2 (URL then) works for me - with Adobe Flash 11.7.700.169, Firefox 20.0.1 (German), Win7 64 bit (German).

As a workaround you could try the new editor "iD" (click the triangle beneath "edit"). Does this work - it should?

(12 May '13, 19:58) aseerel4c26 ♦

That's right Potlatch does not load. I've also tried IE and Google Chrome but still get the same error I can use iD OK but would really like to get Potlatch working again

(12 May '13, 23:52) alantw

@alantw: I am not sure if the admins can make any sense of that info we have collected now - but I have written an email to them pointing to here. They replied that you should contact the admins by yourself

If you have another account or if your friend has one: does it work with it on your pc?

(13 May '13, 00:27) aseerel4c26 ♦
showing 5 of 6 show 1 more comments

The question has been closed for the following reason "The question is answered, server problem is fixed." by aseerel4c26 13 May '13, 23:49

I think that error page will probably have told you to contact and if it didn't then it probably should have done. Nobody else is going to be able to help you.

I believe I have now found and fixed this specific problem however.

permanent link

answered 13 May '13, 00:35

TomH's gravatar image

TomH ♦♦
accept rate: 20%

edited 13 May '13, 00:55


Sorry about the delay in replying but I've been away from my PC all day.

Yes it is now fixed, thank you very much, I would be very interested to know what was causing the problem

(13 May '13, 23:01) alantw

It was a problem that only occurred when the locale selection code couldn't find a match and hat to fall back to the default locale, so your "en_us" language setting was the trigger in your case.

(13 May '13, 23:05) TomH ♦♦

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 11 May '13, 11:29

question was seen: 4,601 times

last updated: 15 Dec '18, 12:26

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum