13
1

I am trying to edit some data and I am getting the following error message upon hitting the edit tab:

      "Editing failed - make sure JOSM or Merkaartor is loaded and the remote control option is enabled".

I have JOSM loaded, but not sure how or where, to enable the 'remote control option'.

This question is marked "community wiki".

asked 15 Jan '11, 01:13

Bennet%20Campoverde's gravatar image

Bennet Campo...
31345
accept rate: 0%

edited 30 Apr '15, 17:00

aseerel4c26's gravatar image

aseerel4c26 ♦
28.4k14211488

What browser do you use? The noscript addon for Firefox will interfere with remote control.

(12 Feb '11, 18:59) emj
5

The thing in NoScript that interferes with JOSM remote control is the ABE, the Application Boundaries Enforcer. The ABE by default prevents pages on the internet from fiddling around with your local computer. You will find the ABE settings under the Advanced tab in the NoScript options dialog. Either you may disable the ABE completely (lazy, but somewhat bad idea) or write a customized ruleset that lets the commands to JOSM pass through.

The documentation is found here: http://noscript.net/abe/

(12 Feb '11, 21:03) gnurk

… for this NoScript issue see an answer below.

(30 Jul '14, 20:11) aseerel4c26 ♦

I had the same problem and this is my solution: I changed the system-ABE from

Site LOCAL Accept from LOCAL Deny

to

Site LOCAL Accept from LOCAL Accept from *.openstreetmap.org Deny

(28 May '15, 07:33) caigner

I have the exact same error message: "Editing failed - make sure JOSM or Merkaartor is loaded and the remote control option is enabled", and I see the answer:

Site LOCAL Accept from LOCAL Deny to Site LOCAL Accept from LOCAL Accept from *.openstreetmap.org Deny

However, as non-expert I do not know in what file to make this change and where this file resides. A search in my computer (windows 7) for the extension ".abe" returns nothing.

Can some one please tell me in detail how to get this editor started?

max

(06 Jun, 20:01) maxwyss

@maxwyss, you do not edit file, that is an option in NoScript dialogs... see other answers like this https://help.openstreetmap.org/answer_link/24836/

(07 Jun, 02:28) Matija Nalis
showing 5 of 6 show 1 more comments

22

also, if you're started having problems in April of 2014 or later, it could be the HTTPS certificate problem, as OpenStreetMap "Edit with remote control" started using HTTPS port on TCP/8112 (it used plaintext HTTP on TCP/8111 before, so there was no certificate and no problem).

To fix it, go to https://127.0.0.1:8112/ and accept invalid certificate.

See github issue 740 for more info

permanent link

answered 09 Jun '14, 18:50

Matija%20Nalis's gravatar image

Matija Nalis
6611611
accept rate: 14%

2

Thanks, your answer help me to deal with that problem. I tried since a week and nothing in the JOSM wiki page Help/Preferences/RemoteControl helps to resolve that.

(30 Jul '14, 19:15) FabienT

@FabienT you should probably report that to JOSM help web page maintainer (or fix it yourself if you have wiki account there)

(31 Jul '14, 13:49) Matija Nalis
1

@Matija Nalis and @FabienT: I just have added a paragraph to this wiki page.

(31 Jul '14, 14:06) aseerel4c26 ♦
11

In the JOSM menu select Edit/Preferences.../ or press F12

Click on the remote control icon

Select "Enable Remote Control" and click OK.

(If you have a JOSM version older than 3715, then RemoteControl is only available as a plugin. You can either get the plugin, or update JOSM.)

permanent link

answered 15 Jan '11, 09:40

gnurk's gravatar image

gnurk
6.0k106095
accept rate: 15%

edited 15 Jan '11, 09:52

Frederik%20Ramm's gravatar image

Frederik Ramm ♦
61.5k75573959

I think JOSM should come with the remote control turned ON by default (maybe it already does since I my configuration files are quite old, I only update the program file).

(30 Dec '11, 10:07) Kozuch

In my experience on Ubuntu and MacOS, JOSM has to be up and running for the remote control to work. So I start JOSM, go back to the browser and then select edit in remote control with JOSM.

(02 Aug '13, 15:16) stf

does anybody have a .jar file of the old remote control plugin?

I am trying to get this working on an old Java 5 system running JOSM 3377, and the automatic plugin downloading no longer works. thanks

(29 Jan '15, 18:14) M Toups

If the problem is NoScript then you can to allow the request through the ABE blocker rules as follows:

1) Open the NoScripts options dialog,
2) Goto the Advanced pane then the ABE sub-pane
3) Change the SYSTEM rule to read:

Site http://127.0.0.1:8111
Accept from *.openstreetmap.org
Deny

Site LOCAL
Accept from LOCAL
Deny
permanent link

answered 02 Aug '13, 12:55

Joe%20E's gravatar image

Joe E
9121
accept rate: 0%

2

If one does not like wildcards and likes also other OSM-related sites to be able to call JOSM, use something like this:

# LOCAL
## Allow
### JOSM call is allowed from OSM related sites
Site 127.0.0.1:8111 localhost:8111 127.0.0.1:8112 localhost:8112
Accept GET from www.openstreetmap.org maps.skobbler.de tools.geofabrik.de overpass-turbo.eu taginfo.openstreetmap.org keepright.ipax.at keepright.at ra.osmsurround.org map.project-osrm.org
Deny

## Deny all others - prevent Internet sites from requesting LAN resources.
Site LOCAL
Accept from LOCAL
Deny
(03 Aug '13, 00:41) aseerel4c26 ♦

You may also run into this problem when using the JOSM remote control links from maproulette.org.

Site 127.0.0.1:8111
Accept from maproulette.org

placed in front of the general DENY rule will help here too.

(30 Mar '14, 16:14) Chaos99

If you are using Opera there are also security issues in the browser that you need to address. The warning it would normally show is hidden in an invisible iframe so the edit option silently fails. To overcome this you can go into Preferences (Ctrl-F12), Advanced, Security, Trusted Websites, Secure Internal Hosts and add 127.0.0.1 (openstreetmap.org edit option) and localhost (OSM Inspector). I guess there may be security issues that permanently flagging the sites as secure may raise, but as the links work with other browsers I don't think that it can be a major risk.

permanent link

answered 15 Jan '11, 12:34

EdLoach's gravatar image

EdLoach ♦
16.4k14134236
accept rate: 23%

edited 11 Feb '11, 15:15

I had another problem with remote control not working today. Here is what I did to troubleshoot it:

First, I started JOSM, and verified it had "Enable remote control" and "Enable HTTPS support" enabled. It was, so I didn't need to enable it and restart JOSM. Next I did in shell:

telnet localhost 8112

if it said the following:

Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

Then it would mean that JOSM, networking and local firewall on the machine are working, and that the problem is somewhere in the web browser (for which I'd then try to open "https://localhost:8112/" to debug further, whitelist certicates etc).

But in my case it hanged after "Trying 127.0.0.1..." and never showed "Connected to 127.0.0.1", which indicated that the problem is either JOSM or network/firewall. Then I did:

netstat -tlpn

to verify if JOSM is listening (that is on Debian GNU/Linux,on MS-windows it would be something like "netstat -a"?):

It should output something like:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp6       0      0 ::1:8111                :::*                    LISTEN      20297/java
tcp6       0      0 127.0.0.1:8111          :::*                    LISTEN      20297/java
tcp6       0      0 ::1:8112                :::*                    LISTEN      20297/java
tcp6       0      0 127.0.0.1:8112          :::*                    LISTEN      20297/java

to indicate JOSM is listening on both port 8111 and 8112. But in my case the list was empty. If it wasn't empty, it would strongly indicate problem in local firewall, so I'd try disabling firewall and trying "telnet" again. But as it was empty, it indicated that problem is that JOSM didn't listen on that port - which is either problem in JOSM (less likely, as I was running stable version and lots of people would be making noise about it) or a problem in local machine networking.

I found a log in ~/.xsession-errors, and it contained:

WARNING: Cannot start IPv4 remotecontrol server on port 8111: Cannot assign requested address (Bind failed)
WARNING: Cannot start IPv6 remotecontrol server on port 8111: Cannot assign requested address (Bind failed)
WARNING: Cannot start IPv4 remotecontrol https server on port 8112: Cannot assign requested address (Bind failed)
WARNING: Cannot start IPv6 remotecontrol https server on port 8112: Cannot assign requested address (Bind failed)

then I started JOSM manually under strace with:

strace -o /tmp/log.txt -s999 -tt -f java -jar josm-tested.jar
grep -w 8112 /tmp/log.txt

and it showed:

bind(38, {sa_family=AF_INET6, sin6_port=htons(8112), inet_pton(AF_INET6, "::ffff:127.0.0.1", &sin6_addr), sin6_flowinfo=htonl(0), sin6_scope_id=0}, 28) = -1 EADDRNOTAVAIL (Cannot assign requested address)

"EADDRNOTAVAIL" means that no network interface on computer has requested address (127.0.0.1 in this case). I did "ip addr show" and found out that my computer really did not have "127.0.0.1" as the "lo" interface was down due to some other problem. So simple "/etc/init.d/networking start" fixed it (which is unlikely to be anybody elses problem, but hopefully those troubleshooting steps would help to narrow down problem).

permanent link

answered 02 Oct, 16:56

Matija%20Nalis's gravatar image

Matija Nalis
6611611
accept rate: 14%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×410
×275
×69
×11

question asked: 15 Jan '11, 01:13

question was seen: 24,611 times

last updated: 02 Oct, 16:56

powered by OSQA