Hi,

I am trying to import an .osm file to my postgres database but I keep getting the following error: Files was unexpected at this time.

Command I used to import the file: osmosis --read-xml file="D:\Licenta\Romania OSM\romania.osm" --write-apidb host="localhost:5432" database="romania" user="postgres" password="mypostgrespassword"

Any idea why I am getting this error?

Thank you

asked 20 Mar '13, 12:53

raduzugravu's gravatar image

raduzugravu
316610
accept rate: 0%

closed 25 Mar '13, 14:41

SomeoneElse's gravatar image

SomeoneElse ♦
33.2k65344785

The question has been closed for the following reason "The questioner has answered their own question and provided the resolution for the benefit of others." by SomeoneElse 25 Mar '13, 14:41


I solved this problem by setting the correct path to java.exe. You can do this by editing osmosis.bat in bin directory and setting JAVACMD to the correct path. This worked for me.

permanent link

answered 25 Mar '13, 14:29

raduzugravu's gravatar image

raduzugravu
316610
accept rate: 0%

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×251
×179

question asked: 20 Mar '13, 12:53

question was seen: 3,393 times

last updated: 25 Mar '13, 14:41

powered by OSQA