Why does the background colour change in Mapnik from zoom level 18 to 17?

Example:

http://www.openstreetmap.org/?lat=-26.83108&lon=-65.19923&zoom=18&layers=M

http://www.openstreetmap.org/?lat=-26.83108&lon=-65.19923&zoom=17&layers=M

"Background" changes from grey to violet / pink.

The behaviour is the same in this area for IE8 and FF3.6 .

asked 06 Jan '11, 15:03

ALE's gravatar image

ALE
1.9k385471
accept rate: 14%

Although the areas you linked are not longer affected, there are many others that are still affected:

http://www.openstreetmap.org/?lat=-1.20704&lon=116.82483&zoom=17&layers=M

http://www.openstreetmap.org/?lat=-2.85286&lon=-78.99426&zoom=17&layers=M

I have not clue if it is related, but the North Pole and South Pole are rendered close to Africa:

http://www.openstreetmap.org/?lat=-0.0001&lon=0.00001&zoom=17&layers=C

http://www.openstreetmap.org/?lat=0&lon=0&zoom=17&layers=M

(14 Mar '11, 13:16) temporalista

Thank you for adding a comment to the respectiv trac: http://trac.openstreetmap.org/ticket/3441

(15 Mar '11, 15:49) ALE

That seems to be a bug in the renderer or an old style-file for this tile.

That should be fixed soon.

If nor or if you notice other bugs you can report them at the trac. Select "mapnik" as Component.

permanent link

answered 07 Jan '11, 10:01

josias's gravatar image

josias
59871523
accept rate: 33%

I think the problem is now solved.

(24 Feb '11, 13:13) ALE

The trac ticket linked below is still open, and the area linked in the ticket is still affected.

(25 Feb '11, 00:04) emj
1

Where is this area exactly. Because I get for both tiles which a rendered in grey. Could you please check again?

(25 Feb '11, 08:00) ALE

trac ticket linked in the answer below.

(25 Feb '11, 11:15) emj
1

there doesn't seem to be any problem any more.

(27 Feb '11, 16:05) dieterdreist

@dieterdreist: Yes, but still no reason to vote down the question.

(05 Mar '11, 00:05) ALE
showing 5 of 7 show 2 more comments

EDIT: there is a trac ticket for it it's apparently all over the world.

I don't think this is a stylesheet issue. I rerendered both zoom layers today:

permanent link

answered 14 Jan '11, 11:39

emj's gravatar image

emj
1.9k123447
accept rate: 15%

edited 14 Jan '11, 11:48

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×370
×308

question asked: 06 Jan '11, 15:03

question was seen: 4,364 times

last updated: 15 Mar '11, 15:49

powered by OSQA