Since I'd upgraded to JOSM 3751 from 3701 I get red Error tiles around my local Imagery tiles. I'm using separate tms-servers for different local map areas but the tiles doesn't overlap. The red Error tiles though are overlapping the tiles from other servers. Is there a way to not show the red tiles?? I'm new to this so maybe I've missed some setting for this.

I also have a problem with cached Imagery tiles. I have a server on my computer for local tiles but when I changed some of them I still get the old images, its not updating from the server. I've tried to Flush tile cache but nothing happens. If I change the menu name for the Imagery then it will use the updated tiles. I've tried to find the cached tiles but no luck...

asked 05 Jan '11, 21:28

Divvi's gravatar image

Divvi
66225
accept rate: 0%

edited 07 Jan '11, 17:47

Richlv's gravatar image

Richlv
1.6k132936


On Unix-like systems Imagery plugin cached tiles will be found in :

~/.josm/plugins/imagery/cache

For the older wmsplugin they will be, unsurprisingly, found in :

~/.josm/plugins/wmsplugin/cache

permanent link

answered 07 Jan '11, 15:48

Richlv's gravatar image

Richlv
1.6k132936
accept rate: 29%

Each server corresponds to a different layer in the Imagery plugin, so make sure you have your layers visible in the right sidebar by pressing Alt+L or clicking the icon that looks like a little stack of paper in the left-hand vertical toolbar. You should see layer names like "Data Layer 1" or "Downloaded GPX Data", and more importantly all your TMS and WMS server layers.

You should then be able to click the little eye icon next to each layer to hide or show it. Sadly there doesn't seem to be a setting for turning off the ugly red error squares.

If only some zoom levels give you red error tiles (sometimes the server won't support 17 or 18 or higher for TMS, for example), try Edit→Preferences (F12), "WMS TMS" tab, and enter a maximum zoom for the problem servers. You may need to purge your cache to see any effect.

permanent link

answered 07 Jan '11, 17:41

Andrew%20Chadwick's gravatar image

Andrew Chadwick
1.1k71721
accept rate: 25%

The server/data layers I use only cover a small area each (no data outside that area). So it's like a jigsaw/picture puzzle. Too bad you can't turn off the error tiles because then I can only work on/see one area at the time...

(10 Jan '11, 22:37) Divvi

On the 23.Jan. 2011 I upgraded to JOSM 3751 and had the same symptoms:

Red error tiles overlaying the Bing imagery.

NOTE: I am using a German version of JOSM so the following word translations to English could well be wrong!

I went to "Einstellungen" i.e. F12 (Perhaps "Setup" in English) - pressed the WMS TMS button to go to "Einstellungen für Hintergrundebene" (Setup for Backgroud levels) - The list of "Bilddienste" (Picture Services/Providers) was:


Bing Sat bing:bing

Bing Sat bing:bing?

LandSat wms:http://onearth.jpl.nasa.gov/wms.cgi?request=GetMap&layers=global_mosaic&styles=&format=image/jpeg&

LandSat wms:http://onearth.jpl.nasa.gov/wms.cgi?request=GetMap&layers=global_mosaic&styles=&srs=EPSG:4326&format=image/jpeg

Landsat (Spiegelserver) wms:http://irs.gis-lab.info/?layers=landsat&

OpenAerial-Karte wms:http://openaerialmap.org/wms/? VERSION=1.0&request=GetMap&layers=world&styles=&srs=EPSG:4326&format=image/jpeg

OpenStreetMap tms:http://tile.openstreetmap.org/

Yahoo Sat html:http://josm.openstreetmap.de/wmsplugin/YahooDirect.html? -


As I could not see the point of the second line Bing:Bing? I elimated it and after a JOSM restart Bing imagery worked perfectly!

permanent link

answered 23 Jan '11, 08:32

dcp's gravatar image

dcp
687344253
accept rate: 0%

edited 23 Jan '11, 08:35

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×513
×235
×64
×46

question asked: 05 Jan '11, 21:28

question was seen: 6,172 times

last updated: 23 Jan '11, 08:35

powered by OSQA