When I upload a gps trace in OSM, the trace never appears in my gps trace section under OSM. I have no error message and the status "waiting" is wrote near a text. After a few minutes, this entry disappears from the page. What happens ? How I can add new trace ?

Update: Your are right, I have mails with this message :

"Found no good GPX points in the input data. At least 75% of the trackpoints lacked a <time> tag."

I don't what is the source of the problem. The trace come directly from my Garmin gps.

Does somebody have already experienced this problem ?

asked 24 Feb '13, 17:08

amaya's gravatar image

amaya
15112
accept rate: 0%

edited 24 Feb '13, 18:06

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551

2

could you please have a look into your mailbox - maybe there is an error message. Maybe your gpx files are invalid xml or do not contain one track (please only use one track per file). [Just edit your question text to add information or use the comment function.]

(24 Feb '13, 17:42) aseerel4c26 ♦

Thanks for your additional comment. Please see GPX#Why_didn.27t_my_GPX_file_upload_properly. You probably have not used the "active log" from your garmin device but a saved track (which looses much of the recorded data on some devices). Also see other questions containing "gpx" and "time".

The page Recording_GPS_tracks (and the linked pages) may also be helpful to you in general.

permanent link

answered 24 Feb '13, 18:03

aseerel4c26's gravatar image

aseerel4c26 ♦
32.1k16239551
accept rate: 17%

edited 24 Feb '13, 21:48

4

When I use the track named "active log", the importation works correctly. thank for your help.

(24 Feb '13, 18:35) amaya

I have had that happen too. If your GPS track does not have a timestamp for every lat/lon point, it will be rejected by the OSM server. I discovered that when I trisd to load a track that I had saved in Google Earth but not on my computer.

I converted my track back to GPX and tried to load it to OSM and had the very same result as you. Google Earth tosses the time stamps when you upload and save a GPX track. Many GPSrs, older Garmins like the 60 series in particular, also strip some of the data from a GPS track when you save it on the unit.

I did find a workaround if the track you want to use is important to get into OSM. Using GPSBabel in command line mode, you can force it to add dummy timestamps to a GPX file. If you're interested enough and are reasonably comfortable using a program from the Windows command window, read the GPSBabel help under Faketime. Here is the command line I used:

C:\Program Files (x86)\GPSBabel>gpsbabel -i gpx -f c:\in.gpx -x track, faketime=f20080705130705+2 -o gpx -F c:\out.gpx

faketime format: YYYYMMDDHHMMSS+SS (offset each point)

Here I used Jul 05, 2008 at 13:07:05 for a start time with a 2 second offset added to each lat/lon pair.

GPSBabel is a sweet program. It can do many things besides convert GPS data from virtually any format into any other format.

permanent link

answered 25 Feb '13, 08:50

AlaskaDave's gravatar image

AlaskaDave
3.9k7093141
accept rate: 12%

1
(25 Feb '13, 09:40) andy mackey
1

@AlaskaDave: "track that I had saved in Google Earth" - the google problem again. ;-) It is not very clear what the source of the track in Google Earth is - tracing their aerial imagery is not allowed for OSM. Can one also download data from Garmins with Google Earth?

Btw: it is not a bug that tracks without timestamps are rejected. The timestamps are useful to see which speed the gps track was recorded at! So, introducing a fake speed is not a good idea unless it really "is important" to have a track without speed info in OSM. If possible speed data should be uploaded.

(25 Feb '13, 13:17) aseerel4c26 ♦
2

Aseere,

Clarification: It was MY OWN trace. I uploaded it to GE for fun and subsequently lost my original data. Seeing as it is my own data and only exists in my private, local KML data file, I have every right to use it. I downloaded it as a KML file and used GPSBabel to convert it back to GPX format after which I uploaded it to OSM where it was rejected.

After I discovered why the OSM server had rejected it I faked the time stamps. The "fake speed" is of no consequence to my purpose which was only to show the hiking trail's physical location and that a trail exists in that area.

(25 Feb '13, 16:29) AlaskaDave

@AlaskaDave: Thank you, very good! Sorry for being nitpicky/pedantic - I think it is important to be sure that newbies reading here don't understand that wrongly and copy from google's data.

(25 Feb '13, 23:28) aseerel4c26 ♦

You can add fake time to GPX by converting it with gpsbabel tool like this:

gpsbabel -i kml -f $file -x track,faketime=20120901000001 -o gpx -F ${file}.gpx
permanent link

answered 12 Mar '13, 04:44

int_ua's gravatar image

int_ua
24591119
accept rate: 0%

1

that is the same (except that you seem to use a kml file as input, which is not mentioned in the question) what AlaskaDave already wrote.

(12 Mar '13, 15:58) aseerel4c26 ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×236
×224
×97
×37
×18

question asked: 24 Feb '13, 17:08

question was seen: 10,285 times

last updated: 12 Mar '13, 15:58

powered by OSQA